summaryrefslogtreecommitdiff
path: root/dev-python/subunit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
commit85ba3f2cfe9ff2b952efb1f3c3c08840f8093246 (patch)
treec8adb7f2695744136c00d176bd0ebd80677049aa /dev-python/subunit
parentf9c971dedd369d9f45a38f3fae51467e864f5324 (diff)
gentoo auto-resync : 07:11:2022 - 09:21:27
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/Manifest2
-rw-r--r--dev-python/subunit/subunit-1.4.1.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/subunit/Manifest b/dev-python/subunit/Manifest
index 25d09bf196fd..4ac34173293a 100644
--- a/dev-python/subunit/Manifest
+++ b/dev-python/subunit/Manifest
@@ -1,4 +1,6 @@
AUX subunit-1.4.0-werror.patch 1307 BLAKE2B e714e82827c0c30b514ea9f43dfcff1702bd93b9e4f1e5c44029a84deb3de8c84a351baec097b545dc00ac7f0d56f85b917a53c23d501a8b93c35632d43c14d1 SHA512 444b4d2755b395f904dd341992cd2d7df60924b4111e552b6a61b6c6113397b3b6e4dd12b2bab7d408a306b3037e361217c7cda5473d94ca746ceab4e1136cbd
DIST subunit-1.4.0_p20210729.tar.gz 112644 BLAKE2B 56e785c029f3f2896d0ed3d8005c37403e6aa32d05b653db0e3b679d2157820558e578b53133f4f79404a660f37a710aeeec03ff941fd7cd0819020a0d474515 SHA512 90b1ad071fb5246a7446a4c999142566b9d96c39838905e9020b80f2f0aba0b86dd5185bbd25ff7fc65f69ae68e1e53dfde5b2de05755aa97db9248c6faaa9d7
+DIST subunit-1.4.1.gh.tar.gz 112188 BLAKE2B dd09882f13b52e8c1f34f91ee49726f75f473a042b0e025704eb95681e4ff3f313fc6b2f9fbcc78f4fb75c88e3b2a828ffee0f7dfaaa8ad2bff9bfb14bd5c0ea SHA512 c21ab0791ccc92e47df5d741deaae56fffe792777958193727f47c2739135fb77880d30b106e525239c0c35841834dd937e2b30fce27fbe73ca9116753147a65
EBUILD subunit-1.4.0_p20210729.ebuild 2261 BLAKE2B cc3082e3d24817d6712840460d10d525ab998e43ffe62c726153e187c50602f54fccafa814f7f59e963a36fbe275637392ff86fb3f649168e8e4bb22b49ee015 SHA512 64edea1ae8fb8c95a7793954857f2d464a4591b971e03ee9e91fcbb17b73be1d3377792ad41a74423b1ce2af9831eee1635f26255df60db009ebe0644a0dac1b
+EBUILD subunit-1.4.1.ebuild 2048 BLAKE2B 8f47bd0d7c11626d1a546303c912a0a1597ce3d31e5a365a6e373a10c0083e4fd899750638dc5ae797062ce4de68e3cfe937b4e1a79ee6e13b05d831f560827e SHA512 d444d1c5ec7e46ea36704c7e5389bc77f7ff4125e08e1b112cf72d9a1d72de04945d754c77a5bb568f26a539262dbd4162187c97d35ce55f61c00711e0b27c81
MISC metadata.xml 536 BLAKE2B a2d8868bf91b862ea393f908c5ae6924dc70fcfa5e2d58692d61c1a45ae33bb9301c82fc032c5951491857da923bdba56f2ed11c149df7b11a4fd9037d1e5a23 SHA512 15d6a7804d14048e959dcaee03bcb2069110ab930368b2b9c31c78b610fd35beb1f714e3d109de2903dba62600b0013d6ef7f5794e828dcc6b34755e35d1836f
diff --git a/dev-python/subunit/subunit-1.4.1.ebuild b/dev-python/subunit/subunit-1.4.1.ebuild
new file mode 100644
index 000000000000..9f172a5eae8c
--- /dev/null
+++ b/dev-python/subunit/subunit-1.4.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 multilib-minimal autotools
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="
+ https://launchpad.net/subunit/
+ https://pypi.org/project/python-subunit/
+"
+SRC_URI="
+ https://github.com/testing-cabal/subunit/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]
+ dev-lang/perl:=
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}]
+ >=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}]
+ >=virtual/pkgconfig-0-r1
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/subunit-1.4.0-werror.patch"
+)
+
+src_prepare() {
+ # Install perl modules in vendor_perl, bug 534654.
+ export PERL_INSTALLDIRS=vendor
+
+ mv all_tests.py python/ || die
+
+ distutils-r1_src_prepare
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+ multilib_is_native_abi && distutils-r1_src_compile
+}
+
+python_test() {
+ cd python || die
+ "${EPYTHON}" -m testtools.run -v all_tests.test_suite ||
+ die "Testing failed with ${EPYTHON}"
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ local targets=(
+ install-include_subunitHEADERS
+ install-pcdataDATA
+ install-exec-local
+ install-libLTLIBRARIES
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+
+ multilib_is_native_abi && distutils-r1_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}