summaryrefslogtreecommitdiff
path: root/dev-python/subunit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/subunit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/Manifest4
-rw-r--r--dev-python/subunit/files/1.0.0-tests.patch25
-rw-r--r--dev-python/subunit/metadata.xml15
-rw-r--r--dev-python/subunit/subunit-1.2.0-r1.ebuild95
4 files changed, 139 insertions, 0 deletions
diff --git a/dev-python/subunit/Manifest b/dev-python/subunit/Manifest
new file mode 100644
index 000000000000..24c2946feb60
--- /dev/null
+++ b/dev-python/subunit/Manifest
@@ -0,0 +1,4 @@
+AUX 1.0.0-tests.patch 1058 BLAKE2B 4373418085d6382351a99bc6cee59ad8c65b4048ce83df2abf3b4c895976d52de658cd98dd9e3c971d96c185f0e9e82f12c42e6bea7193fd7a960193ebe89cd8 SHA512 b1accf4434415357a8c235c6b660cec440096616887e62fb45a2d15e314a3abb9be825bf4e8ec8d4b18d7ab08197cacd6916bbde87dc5b88c6f3e80ca89b1de0
+DIST subunit-1.2.0.tar.gz 460532 BLAKE2B 7f8a459afc576efed8fbf271a9d2e175ae9de9dda68acb26322f222ac46f12fee5dece4cb2679fca608ba307a3692aa84b13d0e093606bd89a53c69b2081cd44 SHA512 f6559fd771ad0732985230d11a9a8326ef35c817b62d1f50dc332f0032f7b08559a46d2534983b7d3964e45682ac49b3e348581ee0983861390abcd4ec20459c
+EBUILD subunit-1.2.0-r1.ebuild 2655 BLAKE2B de890e7defa47e60771a8111b477cc9768a99c92007e3a70c2d8c57ab6600858ecd7a6d7f3ef2e8b39747e3eccc7507c90ceb23f2ae48f375f6f2d6b54b1bcbf SHA512 ab2f59113e8ce23fa13ba2b86cd1353bdd3de61edc0a001fb972991402238f889d9c279fb53f009fbae8c51e4b17dc607f4728fc89f82e012095d0676921864b
+MISC metadata.xml 422 BLAKE2B 7835651c50d6d889887dc834dcc5a387cfea9c61867570b6c98790a1c7ea49c01a75868f6bec4f31ffc46a38dba51eb2c4ff0b6da8f8acfe6059e11e3db7f727 SHA512 dcac9ba5ff93016141b433c16b9d1a526ec2babd39721d75a6edd235eb6388500ea8228b6c8c88eacbb12c732c36883c0b698f7039aca7909890fe16cb895cb8
diff --git a/dev-python/subunit/files/1.0.0-tests.patch b/dev-python/subunit/files/1.0.0-tests.patch
new file mode 100644
index 000000000000..d83a1900cbe1
--- /dev/null
+++ b/dev-python/subunit/files/1.0.0-tests.patch
@@ -0,0 +1,25 @@
+diff -ur subunit-1.0.0.orig/python/subunit/tests/test_run.py subunit-1.0.0/python/subunit/tests/test_run.py
+--- python/subunit/tests/test_run.py 2014-11-18 16:59:26.000000000 +0800
++++ python/subunit/tests/test_run.py 2015-03-26 13:25:19.193341069 +0800
+@@ -77,21 +77,6 @@
+ exc = self.assertRaises(SystemExit, runner.list, None, loader=loader)
+ self.assertEqual((2,), exc.args)
+
+- class FailingTest(TestCase):
+- def test_fail(self):
+- 1/0
+-
+- def test_exits_zero_when_tests_fail(self):
+- bytestream = io.BytesIO()
+- stream = io.TextIOWrapper(bytestream, encoding="utf8")
+- try:
+- self.assertEqual(None, run.main(
+- argv=["progName", "subunit.tests.test_run.TestSubunitTestRunner.FailingTest"],
+- stdout=stream))
+- except SystemExit:
+- self.fail("SystemExit raised")
+- self.assertThat(bytestream.getvalue(), StartsWith(_b('\xb3')))
+-
+ class ExitingTest(TestCase):
+ def test_exit(self):
+ raise SystemExit(0)
diff --git a/dev-python/subunit/metadata.xml b/dev-python/subunit/metadata.xml
new file mode 100644
index 000000000000..e42cdff158cf
--- /dev/null
+++ b/dev-python/subunit/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">subunit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/subunit/subunit-1.2.0-r1.ebuild b/dev-python/subunit/subunit-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..4212993688a8
--- /dev/null
+++ b/dev-python/subunit/subunit-1.2.0-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils multilib-minimal versionator
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit https://pypi.org/project/python-subunit/"
+SRC_URI="https://launchpad.net/${PN}/trunk/$(get_version_component_range 1-2)/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs test"
+
+RDEPEND="
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]
+ dev-lang/perl:="
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}]
+ >=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}]
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )"
+
+# Take out rogue & trivial failing tests that exit the suite before it even gets started
+# The removed class in fact works fine in py3 and fails with py2.7 & pupu
+# The setu to restrict this patch is just those 2 is not worth it.
+PATCHES=( "${FILESDIR}"/1.0.0-tests.patch )
+
+src_prepare() {
+ sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die
+
+ # Install perl modules in vendor_perl, bug 534654.
+ export INSTALLDIRS=vendor
+
+ # needed for perl modules
+ distutils-r1_src_prepare
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+ multilib_is_native_abi && distutils-r1_src_compile
+}
+
+python_test() {
+ local -x PATH="${PWD}/shell/share:${PATH}"
+ local -x PYTHONPATH=python
+ # Following tests are known to fail in py2.7 & pypy. They pass under py3.
+ # DO NOT re-file
+ # test_add_error test_add_error_details test_add_expected_failure
+ # test_add_expected_failure_details test_add_failure test_add_failure
+ # https://bugs.launchpad.net/subunit/+bug/1436686
+
+ "${PYTHON}" -m testtools.run all_tests.test_suite || die "Testing failed with ${EPYTHON}"
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ local targets=(
+ install-include_subunitHEADERS
+ install-pcdataDATA
+ install-exec-local
+ install-libLTLIBRARIES
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+
+ multilib_is_native_abi && distutils-r1_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}