summaryrefslogtreecommitdiff
path: root/dev-python/subunit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/subunit
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/Manifest4
-rw-r--r--dev-python/subunit/metadata.xml1
-rw-r--r--dev-python/subunit/subunit-1.4.0_p20210729.ebuild99
3 files changed, 103 insertions, 1 deletions
diff --git a/dev-python/subunit/Manifest b/dev-python/subunit/Manifest
index eb982ddfa231..148cfb4affaf 100644
--- a/dev-python/subunit/Manifest
+++ b/dev-python/subunit/Manifest
@@ -1,4 +1,6 @@
AUX subunit-1.4.0-werror.patch 1307 BLAKE2B e714e82827c0c30b514ea9f43dfcff1702bd93b9e4f1e5c44029a84deb3de8c84a351baec097b545dc00ac7f0d56f85b917a53c23d501a8b93c35632d43c14d1 SHA512 444b4d2755b395f904dd341992cd2d7df60924b4111e552b6a61b6c6113397b3b6e4dd12b2bab7d408a306b3037e361217c7cda5473d94ca746ceab4e1136cbd
DIST subunit-1.4.0.tar.gz 488022 BLAKE2B 4c3a714d02eeed9420074c4e032778a69b716a5cad0079193533e9bc8c0f4576d70b165eb413203ce8a916ac28466e9f5a113d4a7746019d7d09409df9860bae SHA512 5d2e3cb96c09067ef4595c86648f13330c810b19e39c0b35bc9546c57bee957ddcf5cad7b8e3f92bda9b54dcdbf175863e2f6ba94020f880230459be7afdbbcf
+DIST subunit-1.4.0_p20210729.tar.gz 112644 BLAKE2B 56e785c029f3f2896d0ed3d8005c37403e6aa32d05b653db0e3b679d2157820558e578b53133f4f79404a660f37a710aeeec03ff941fd7cd0819020a0d474515 SHA512 90b1ad071fb5246a7446a4c999142566b9d96c39838905e9020b80f2f0aba0b86dd5185bbd25ff7fc65f69ae68e1e53dfde5b2de05755aa97db9248c6faaa9d7
EBUILD subunit-1.4.0.ebuild 2589 BLAKE2B 6910487596f619830a195e448eda159753c2a6c776c1ec128086f5fe5f859e028088f16b889559b7256e63668ed86d0fa92d34597442ffee44bc348f699f2a10 SHA512 6ec43969be84272430101edc9e645a182c02951cb5ca6df1dbfcd8b3b82ea262548979cc1a770a3d49ea3838a497e8456d3c82bf41e3bab5e8a21d8f81b996e1
-MISC metadata.xml 475 BLAKE2B 6773520b663ffb97362a99c1472833d54c31a51bf7694691d669138c69f9c3a27f020a05dd68d13e2c99bd4e7d597890eaca6d981b132d1ae01c89909eed63cb SHA512 2b64a01e91f6faeaf8f8455821d5edd1d2233056544ea0c0bce46f79346d6e974fcd2f3ecbf98d35cda6fdaabe555683dd13c1d77258a7a9a8b4bcaeb9ac0b7f
+EBUILD subunit-1.4.0_p20210729.ebuild 2261 BLAKE2B 54b52db12e896f057f7976e396a2444d9fcbbafb7847c965be837f18e16185142633f1dc48d476c4cc0fccc4b78aee9f5fb10a22718107826198b4a7b4e6be0b SHA512 28b9689967cc262e7c0211c6f5fa877e0e64a7ba6e92e63e20b6afb1fc75afca297eb3678bb16c619ecdacb5f0b78156e16d1bb15eb4454ab337b7be61a23cff
+MISC metadata.xml 536 BLAKE2B a2d8868bf91b862ea393f908c5ae6924dc70fcfa5e2d58692d61c1a45ae33bb9301c82fc032c5951491857da923bdba56f2ed11c149df7b11a4fd9037d1e5a23 SHA512 15d6a7804d14048e959dcaee03bcb2069110ab930368b2b9c31c78b610fd35beb1f714e3d109de2903dba62600b0013d6ef7f5794e828dcc6b34755e35d1836f
diff --git a/dev-python/subunit/metadata.xml b/dev-python/subunit/metadata.xml
index 0eaaa4c9575c..d7e73ee6e3af 100644
--- a/dev-python/subunit/metadata.xml
+++ b/dev-python/subunit/metadata.xml
@@ -12,5 +12,6 @@
<upstream>
<remote-id type="launchpad">subunit</remote-id>
<remote-id type="pypi">python-subunit</remote-id>
+ <remote-id type="github">testing-cabal/subunit</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/subunit/subunit-1.4.0_p20210729.ebuild b/dev-python/subunit/subunit-1.4.0_p20210729.ebuild
new file mode 100644
index 000000000000..2fbb1719b152
--- /dev/null
+++ b/dev-python/subunit/subunit-1.4.0_p20210729.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 multilib-minimal autotools
+
+MY_COMMIT="c87ffbd904627d777aa1430963dced92a36aa033"
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit https://pypi.org/project/python-subunit/"
+SRC_URI="
+ https://github.com/testing-cabal/subunit/archive/${MY_COMMIT}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]
+ dev-lang/perl:="
+
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}]
+ >=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}]
+ >=virtual/pkgconfig-0-r1
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/subunit-1.4.0-werror.patch"
+)
+
+src_prepare() {
+ sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die
+
+ # Install perl modules in vendor_perl, bug 534654.
+ export INSTALLDIRS=vendor
+
+ # fails on py3.6
+ sed -i -e 's:test_add_tag:_&:' \
+ python/subunit/tests/test_subunit_tags.py || die
+
+ mv all_tests.py python/ || die
+
+ distutils-r1_src_prepare
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+ multilib_is_native_abi && distutils-r1_src_compile
+}
+
+python_test() {
+ cd python || die
+ "${PYTHON}" -m testtools.run -v all_tests.test_suite || die "Testing failed with ${EPYTHON}"
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ local targets=(
+ install-include_subunitHEADERS
+ install-pcdataDATA
+ install-exec-local
+ install-libLTLIBRARIES
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+
+ multilib_is_native_abi && distutils-r1_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}