summaryrefslogtreecommitdiff
path: root/dev-python/subprocess32/subprocess32-3.2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/subprocess32/subprocess32-3.2.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/subprocess32/subprocess32-3.2.7.ebuild')
-rw-r--r--dev-python/subprocess32/subprocess32-3.2.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/subprocess32/subprocess32-3.2.7.ebuild b/dev-python/subprocess32/subprocess32-3.2.7.ebuild
new file mode 100644
index 000000000000..0d41da79953f
--- /dev/null
+++ b/dev-python/subprocess32/subprocess32-3.2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A backport of the subprocess module from Python 3.2/3.3 for use on 2.x"
+HOMEPAGE="https://github.com/google/python-subprocess32"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}"/${P}-sandbox-test-fix.patch )
+
+python_test() {
+ "${PYTHON}" test_subprocess32.py || die "Tests fail with ${EPYTHON}"
+}