summaryrefslogtreecommitdiff
path: root/dev-python/stsci-sphinxext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/stsci-sphinxext
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/stsci-sphinxext')
-rw-r--r--dev-python/stsci-sphinxext/Manifest3
-rw-r--r--dev-python/stsci-sphinxext/metadata.xml15
-rw-r--r--dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild30
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/stsci-sphinxext/Manifest b/dev-python/stsci-sphinxext/Manifest
new file mode 100644
index 000000000000..d3ffe3effde9
--- /dev/null
+++ b/dev-python/stsci-sphinxext/Manifest
@@ -0,0 +1,3 @@
+DIST stsci.sphinxext-1.2.1.tar.gz 75591 BLAKE2B dc448475bc5dd888aae50bd4ffdcee222b4de3b9428823c52225e2c2dc7ba66baf09ca2f1770c3a85f44ad380b30d9170db7d610ee9262eb4e4a437f2a9ef15d SHA512 98860d6748a6be00a853b12adb283ec138c8111d7c990c5ae7f493089eb5974943aa9fb101ec8b4f280b77c49d07ce6d44c50384477d57710ded0f3382155943
+EBUILD stsci-sphinxext-1.2.1.ebuild 790 BLAKE2B 891d1835af912d96fef10633e2f2de6df5683ec69fa574c31b863987ec420b4ad407fb9307cb79b43fb89dbeb64b23cfa1eabafb039b010dd62ed3dce60a4859 SHA512 8bb3bcde734c5461f6f3f5ce29e03a29aebcd9827d0e66b2feaaafa1ddba42bd20549130a70a9ad96f7bc1aa2f3b21c199972afad0dade94ea4b0b8d56328fbf
+MISC metadata.xml 477 BLAKE2B 38209c9db401ef2eb730a6a61247dfbb49ad25732417585fc1d423b34e5037439d01c826967d08194280e76ea45669da7ef47e40ee6017d8056530c915dbbb88 SHA512 67126020b606cd33cbfb87afbcd912f75e11393670e2c655e6f4e1b7406eb1db44fb4897b5101526ef4889c71b083547bc255eecf1a53bf097fc293342425862
diff --git a/dev-python/stsci-sphinxext/metadata.xml b/dev-python/stsci-sphinxext/metadata.xml
new file mode 100644
index 000000000000..2c7222a77c29
--- /dev/null
+++ b/dev-python/stsci-sphinxext/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ This project contains extensions to Sphinx to build documentation
+ from Space Telescope Science Institute.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">stsci.sphinxext</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild b/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild
new file mode 100644
index 000000000000..e2fa911999eb
--- /dev/null
+++ b/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Tools and templates to customize Sphinx for STScI projects"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/stsci_python"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpydoc[$(python_gen_usedep python2_7)]"
+DEPEND="${RDEPEND}
+ >=dev-python/d2to1-0.2.9[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/stsci-distutils-0.3.2[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"