summaryrefslogtreecommitdiff
path: root/dev-python/stsci-distutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/stsci-distutils
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/stsci-distutils')
-rw-r--r--dev-python/stsci-distutils/Manifest3
-rw-r--r--dev-python/stsci-distutils/metadata.xml23
-rw-r--r--dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild28
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/stsci-distutils/Manifest b/dev-python/stsci-distutils/Manifest
new file mode 100644
index 000000000000..8e854e3fb0bf
--- /dev/null
+++ b/dev-python/stsci-distutils/Manifest
@@ -0,0 +1,3 @@
+DIST stsci.distutils-0.3.7.tar.gz 48831 BLAKE2B 1c1d0399d4ff7108e24161239655e5db724c2cb2b3aa0f6b92072b45e9935929426cf0dfb39878cba3faacf8575a09a863ff6830ad583e3f9cfc171b92c8890d SHA512 8ef81afe43dc080d28ce7e640c1e03cd0e0a857151ad307af742ef434e3a1abb489213a63a95618bac39a743624510a0d59a2817b6cadb929a2bcf64406ac85e
+EBUILD stsci-distutils-0.3.7.ebuild 638 BLAKE2B 57d0daed49f00935c17007fae55ae76bd5c68798f322b6ab396828ef793ab0133c4b5bdd52516b963ae83e15378f685cf968eadf06a7f50c09286980a9801f35 SHA512 c42d1e64c2a8c1a3f7a09afd57385caf8ac1aeaa92d062a58cc59ac34d0635f748894499bdaae63edd4f3172ebf793b28c3f068888b9ec637b5873e6e774d01b
+MISC metadata.xml 840 BLAKE2B ecf230a9dc003fa83b69f324ff1d6c8b09d34e2aa30d32d2916b22bb9792ff855042dc6b24efb56fa6560d12591a2dfee3d0937ded149e5f4f48405e77372d71 SHA512 c438ce545bc4de08dd5de0d0c0ab3b19dc9b87169d8847078e2e3bcb4fde113f0db7dd073a42a047ae268eaf4e25efece85eeac210b6f2e5260b53de48d4987d
diff --git a/dev-python/stsci-distutils/metadata.xml b/dev-python/stsci-distutils/metadata.xml
new file mode 100644
index 000000000000..e839bf3d66e9
--- /dev/null
+++ b/dev-python/stsci-distutils/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription>
+ This package contains utilities used to package some of STScI's Python
+ projects; specifically those projects that comprise stsci_python and
+ Astrolib.
+ It currently consists mostly of some setup_hook scripts meant for use with
+ distutils2/packaging and/or d2to1, and a customized easy_install command
+ meant for use with distribute.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">stsci.distutils</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild b/dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild
new file mode 100644
index 000000000000..c5e1000823b3
--- /dev/null
+++ b/dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Utilities used to package some of STScI's Python projects"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/stsci_python"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ dev-python/d2to1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"