summaryrefslogtreecommitdiff
path: root/dev-python/structlog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/structlog
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/structlog')
-rw-r--r--dev-python/structlog/Manifest3
-rw-r--r--dev-python/structlog/metadata.xml15
-rw-r--r--dev-python/structlog/structlog-16.1.0.ebuild17
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/structlog/Manifest b/dev-python/structlog/Manifest
new file mode 100644
index 000000000000..8a10125ae450
--- /dev/null
+++ b/dev-python/structlog/Manifest
@@ -0,0 +1,3 @@
+DIST structlog-16.1.0.tar.gz 150604 BLAKE2B 928ad43206eeeb25d76eb2708d8ff8a5c1f886256be98bf18372ade227de96167a9bab855945eb94abb843c09d28799557f759c0a9b2bfbed5004ea6f009e030 SHA512 eafa89516b99adb02527d0b374f12b438e83a961f08cf42aa10a7196ec81df6ad5492772ae7c52747ac926d8f5a7ca8d89cc12f4dc6d37d21b9935f009894a37
+EBUILD structlog-16.1.0.ebuild 475 BLAKE2B 3bd149b59508d994aa2463ee440e4b3aa5215416e0deeb1a690bd960f90422db842f3f277d1a4f4249473ac67a225ca774f7b5ca1d3ac899e3a29436f3153099 SHA512 9c51dfdfacb2020646217ea143baedc7b254dbdb73044c2e85200acb50aa611b94b8984822912396c00640fcf9036c0543a95c6aef70e5f8d2944141d5a37b95
+MISC metadata.xml 475 BLAKE2B 3865bf1c194a666d6ae33aad082e189cc327f669ae90f0daf3135e3e727397b488e3341904fbca5363fb08c8830d585fe6755124909ffde12c6402bdb4c3b6d8 SHA512 68586f9e4f089f6b13ea44afefda4cf2c08a1e91e9d4a6422c78bafc7ff87eb2412918ed8749ddcd91c5e9428c3ae82deae6d79a42985517fb6f554837f4dc7b
diff --git a/dev-python/structlog/metadata.xml b/dev-python/structlog/metadata.xml
new file mode 100644
index 000000000000..f04762cdc67e
--- /dev/null
+++ b/dev-python/structlog/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wizardedit@gentoo.org</email>
+ <name>Austin English</name>
+ </maintainer>
+ <longdescription lang="en">
+ Structured Logging for Python
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">structlog</remote-id>
+ <remote-id type="github">hynek/structlog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/structlog/structlog-16.1.0.ebuild b/dev-python/structlog/structlog-16.1.0.ebuild
new file mode 100644
index 000000000000..d4d703fd2c94
--- /dev/null
+++ b/dev-python/structlog/structlog-16.1.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python2_7 python3_{4,5,6} pypy)
+inherit distutils-r1
+
+DESCRIPTION="Structured Logging for Python"
+HOMEPAGE="http://www.structlog.org/en/stable/"
+SRC_URI="https://github.com/hynek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"