summaryrefslogtreecommitdiff
path: root/dev-python/stripe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-19 06:30:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-19 06:30:51 +0000
commitf8bb2d659372d0add11c589dcb006d0b7f8822ae (patch)
tree5d64f4f593db363260360200660abcd8ff00d1c6 /dev-python/stripe
parentf57e008aa126ccdca95f7424e4d24a1a83a49682 (diff)
gentoo auto-resync : 19:12:2024 - 06:30:51
Diffstat (limited to 'dev-python/stripe')
-rw-r--r--dev-python/stripe/Manifest2
-rw-r--r--dev-python/stripe/stripe-11.4.0.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/stripe/Manifest b/dev-python/stripe/Manifest
index 8bda2d69d6b9..56137c35ccae 100644
--- a/dev-python/stripe/Manifest
+++ b/dev-python/stripe/Manifest
@@ -1,3 +1,5 @@
DIST stripe-11.3.0.tar.gz 1367031 BLAKE2B b46cae95059a1aa7087743772b5cb23456e64b276befa852b0c13ce417f624ac6d9a90e64a43aeb3d60941ad73cc87afa114d4161c5e5b3e5ae6033b4378f6c1 SHA512 4b8934653f138b86f7d64977f2817fc0ad54a89d794521af7d1f193ecdcbb366e78ece286a3c768f946d281aba998443e675e6db66fcd3a0084641053e55a182
+DIST stripe-11.4.0.tar.gz 1378868 BLAKE2B 86444654843d90cd068c8f5b240fbc7f141a128c31b4d85e2b096fa202b5f1a662891f4ac0902725ebb2ec54f61e4fc45558239caa31f7db5c67bfc0c72e758f SHA512 083f9fee32d48c1a4097168871f56b9027f5098e9628b6ac29440ab4fced445b824795ba77129edf1e5cd41f99f086f26475d289d65f2e2fff94103913aa9d6a
EBUILD stripe-11.3.0.ebuild 2575 BLAKE2B 33210bb7d7c1d2b7226ae44251258b39175610fe250a15f785d1f1a0ffa01ab1e8b08c417a624a011598a9dcbe63798f170efd53ab0a70cb381cd940bcb0687c SHA512 fd860eefd8996812fa4e7feafb7f0bb7f575620b5adb496b79c1a78cd70f50ff33e750fdcbe6fca5fbd9eb2fd01e667f2dd06a8478c6b8f62f47d128ce672b50
+EBUILD stripe-11.4.0.ebuild 2578 BLAKE2B 155744e53fff566fdb1605586ab59be6fb9bb056e6e9ca3a2314436265156760e4b462a7effa39a496125829eef4095b3d4f3fdaadd3f8280901d70bde3748de SHA512 4f20c27def982a82d7c647a1e7dd897cabbc6b761ea00367bf22bc635cd1f0a1f91a0e6ec486d88c4bcab7229221bcfadddcea3f156311a9d9c99451b52ed616
MISC metadata.xml 673 BLAKE2B 6b85b1f88713d2365274fcff21648748039b48028b3c34c1192e16ca12d0f3b4d14ab13c7c2a744c381898ea0c1304bda8be52d3fadddc1a1b787f010b001398 SHA512 e3178927a69d14f59673acc5eaedda59db5a07e2145ed6fb0597363b60183cb3e7a7b0feefc1d4c9095d52ed96e0be32ef5dc23ad0c20fd6e6b33c830177c0be
diff --git a/dev-python/stripe/stripe-11.4.0.ebuild b/dev-python/stripe/stripe-11.4.0.ebuild
new file mode 100644
index 000000000000..eb697bfc26cb
--- /dev/null
+++ b/dev-python/stripe/stripe-11.4.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stripe Python bindings"
+HOMEPAGE="
+ https://github.com/stripe/stripe-python/
+ https://pypi.org/project/stripe/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="telemetry"
+
+RDEPEND="
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5.0[${PYTHON_USEDEP}]
+"
+# please bump dev-util/stripe-mock dep to the latest version on every bump
+BDEPEND="
+ test? (
+ >=dev-util/stripe-mock-0.192.0
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ net-misc/curl
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+DOCS=( LONG_DESCRIPTION.rst CHANGELOG.md README.md )
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ if ! use telemetry; then
+ sed -i -e '/enable_telemetry/s:True:False:' stripe/__init__.py || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # exception message mismatch with aiohttp-3.10.0
+ "tests/test_integration.py::TestIntegration::test_async_timeout[asyncio-aiohttp]"
+ "tests/test_integration.py::TestIntegration::test_async_raw_request_timeout[asyncio-aiohttp]"
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests -p anyio -p pytest_mock
+}
+
+src_test() {
+ local stripe_mock_port=12111
+ local stripe_mock_max_port=12121
+ local stripe_mock_logfile="${T}/stripe_mock_${EPYTHON}.log"
+ # Try to start stripe-mock until we find a free port
+ while [[ ${stripe_mock_port} -le ${stripe_mock_max_port} ]]; do
+ ebegin "Trying to start stripe-mock on port ${stripe_mock_port}"
+ stripe-mock --http-port "${stripe_mock_port}" &> "${stripe_mock_logfile}" &
+ local stripe_mock_pid=${!}
+ sleep 2
+ # Did stripe-mock start?
+ curl --fail -u "sk_test_123:" \
+ "http://127.0.0.1:${stripe_mock_port}/v1/customers" &> /dev/null
+ eend ${?} "Port ${stripe_mock_port} unavailable"
+ if [[ ${?} -eq 0 ]]; then
+ einfo "stripe-mock running on port ${stripe_mock_port}"
+ break
+ fi
+ (( stripe_mock_port++ ))
+ done
+ if [[ ${stripe_mock_port} -gt ${stripe_mock_max_port} ]]; then
+ eerror "Unable to start stripe-mock for tests"
+ die "Please see the logfile located at: ${stripe_mock_logfile}"
+ fi
+
+ local -x STRIPE_MOCK_PORT=${stripe_mock_port}
+ distutils-r1_src_test
+
+ # Tear down stripe-mock
+ kill "${stripe_mock_pid}" || die "Unable to stop stripe-mock"
+}