summaryrefslogtreecommitdiff
path: root/dev-python/stripe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/stripe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/stripe')
-rw-r--r--dev-python/stripe/Manifest5
-rw-r--r--dev-python/stripe/metadata.xml18
-rw-r--r--dev-python/stripe/stripe-1.75.3.ebuild21
-rw-r--r--dev-python/stripe/stripe-1.79.1.ebuild21
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/stripe/Manifest b/dev-python/stripe/Manifest
new file mode 100644
index 000000000000..8330d587d691
--- /dev/null
+++ b/dev-python/stripe/Manifest
@@ -0,0 +1,5 @@
+DIST stripe-1.75.3.tar.gz 181924 BLAKE2B acbbc05db9bb7ed61d5ea0995f69164d3c781a54d8e033aa4e74f0d7334993b70f21799a022ede69219c7a23dfa516e8e340b5009b7cb26142ac077dce24babf SHA512 30c95740bbf2a756ebd4e9453195907c8239bd9e36377363429ee269ef27e04fe60bdc3bde921a5be0ad7ab59ea1859dbcfbbf39d6da8b81aa163cfc7793ea5e
+DIST stripe-1.79.1.tar.gz 180317 BLAKE2B 03ea5b816a6892eec4041958c9636b3083da2cb46d98bd2a85da585d51d02b1a809dd57b7507e4c965824a52c5093527b44bdbd18a2defa659c766c8ab17668c SHA512 a3255eb01692816ff6f729af0d77abf9aedad0cc3236c7f4f3172047a45378a1c0f820e1bd38676ad334ff5a9d6d2528ef2f1e021903dfbacb980a3b2dd8a7f8
+EBUILD stripe-1.75.3.ebuild 457 BLAKE2B a2c8a2c7f8de450ce46064be766b8953d80f276bdd0a95e3687ec2cfb28475d1bbbe4353956c2e6c9f765db985baee1651359e4e17baf5ab1ca9a12bf29f6581 SHA512 d8c6012d0957a21bee6a433857796a050cb6de2cd08b67e071cbea9b713ce4d8427fa037d8e263eb99f613093bc270865a7a8650ad6345ddcb45d4238acdfea9
+EBUILD stripe-1.79.1.ebuild 457 BLAKE2B c75936fad3114182081bc7c01c1368e77f85fadc9d8ff52ec491e6a3b241831fe3f2debe1ab66083a4e64937c0038a27bef835653adf51562ee7f2463c0561a5 SHA512 e6e5efc654d511290c041dc3ef8d3e4c09966456fa2f398f23d36aa5ed05a9e30572a88502f67f52ac373c7e9a90cd7c2cf00f9cfa74112d1630ff18f859a310
+MISC metadata.xml 539 BLAKE2B 9232265d094774d1f04cba8e358a9655034184c10561bb8db4f8188381fdf7583971f67d5418f2969ad4a12db46a94b4c87c3eb9486eb0ac251fad9bb68f7707 SHA512 f0052ba8457139d76ddce67313bc973564237b409801d3d6da181c495c2d80184076cbe36468850a1ddcd60de50327e728fc3433a8a4bfe9608713a33fdbe9c1
diff --git a/dev-python/stripe/metadata.xml b/dev-python/stripe/metadata.xml
new file mode 100644
index 000000000000..00a5d2222be1
--- /dev/null
+++ b/dev-python/stripe/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <longdescription lang="en">
+ Official Stripe Bindings for Python
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">stripe</remote-id>
+ <remote-id type="github">stripe/stripe-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stripe/stripe-1.75.3.ebuild b/dev-python/stripe/stripe-1.75.3.ebuild
new file mode 100644
index 000000000000..5c90df0de3ce
--- /dev/null
+++ b/dev-python/stripe/stripe-1.75.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Stripe python bindings"
+HOMEPAGE="https://github.com/stripe/stripe-python"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/requests-0.8.8"
+DEPEND="${RDEPEND}"
+
+DOCS="LONG_DESCRIPTION.rst"
diff --git a/dev-python/stripe/stripe-1.79.1.ebuild b/dev-python/stripe/stripe-1.79.1.ebuild
new file mode 100644
index 000000000000..8c5c55ccdc19
--- /dev/null
+++ b/dev-python/stripe/stripe-1.79.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Stripe python bindings"
+HOMEPAGE="https://github.com/stripe/stripe-python"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/requests-0.8.8"
+DEPEND="${RDEPEND}"
+
+DOCS="LONG_DESCRIPTION.rst"