summaryrefslogtreecommitdiff
path: root/dev-python/stomp-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-python/stomp-py
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/Manifest3
-rw-r--r--dev-python/stomp-py/metadata.xml12
-rw-r--r--dev-python/stomp-py/stomp-py-6.1.0.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
new file mode 100644
index 000000000000..ab4412e42a96
--- /dev/null
+++ b/dev-python/stomp-py/Manifest
@@ -0,0 +1,3 @@
+DIST stomp.py-6.1.0.tar.gz 34690 BLAKE2B bf7ec2899be25bdc373e7d0d73281a6c4aa8b91a05e6ede263f0f9498b2ba3b9bd2c90b0fe472664c930dadf68ccaf09c74b69e7270259c3959396edff04e07b SHA512 73284b5dac8b9ef0d1251cc1059c4b1a545018a39498303d211fd165f0fb80439f2e01f82e18644cfd5d77a4badedcbced57d184ffc7c19f57945e5262f2394a
+EBUILD stomp-py-6.1.0.ebuild 1075 BLAKE2B 4108b6e5a5eea47b52544c4e59dd1876a52773386afef700c8d76a4233e8572aedd22095a1b332119af293402a9788634fea83e6af1593061881d49cff597778 SHA512 65b3b2a294c2e864cc01dba5decb7f3f49b1f5b03782609c7b934f115cb027d3256cb1e90c62b6213bc26f665b6cc349080e47a5c2baf48bd7b3ed71bceb8105
+MISC metadata.xml 377 BLAKE2B 239bc7a6ea8a0ce5cae1bbf292e03629688cd4b89930e1da64885a3f8aeaa1bac842dc2cd5bd352cd71d4d49ba2982e156e2f1099b218b871d56c636580e2688 SHA512 5f5036635fea124c854ad05263897205110f552cbc63b5c21bd98f73fe0de42e448ed0060aa6130f74d9e4b558c1633fbcc09eec3f128b21cdd3ae3936c691f4
diff --git a/dev-python/stomp-py/metadata.xml b/dev-python/stomp-py/metadata.xml
new file mode 100644
index 000000000000..53838ba131f5
--- /dev/null
+++ b/dev-python/stomp-py/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">stomp.py</remote-id>
+ <remote-id type="github">jasonrbriggs/stomp.py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stomp-py/stomp-py-6.1.0.ebuild b/dev-python/stomp-py/stomp-py-6.1.0.ebuild
new file mode 100644
index 000000000000..43324414a605
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-6.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 6.1.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}