summaryrefslogtreecommitdiff
path: root/dev-python/stomp-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/stomp-py
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/Manifest2
-rw-r--r--dev-python/stomp-py/stomp-py-8.0.1.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
index 835c1efcab57..d56cb00f6481 100644
--- a/dev-python/stomp-py/Manifest
+++ b/dev-python/stomp-py/Manifest
@@ -1,3 +1,5 @@
DIST stomp.py-8.0.0.tar.gz 35146 BLAKE2B 65f15e0145e1fc48d4f9ccf37ce81f1f7464e9179d63d6f22e96dd99ce35692dbcb6056730c35255428b0ccf0d744debc39e2c12e6e2b6675ac20c7ec0ff3efd SHA512 068694e9bc42e45dd769275296a1ea817153cb0318b08377be5e0b9563989a83bff35c4bc424e00939b7521938aa34f485401f07a8a51c3d9a90eea3f00c1ea1
+DIST stomp.py-8.0.1.tar.gz 35300 BLAKE2B 12209e99066fb5bb1f3015398f5eb27186322ce9d92feca46adc4d275aff1d5138908da69abe3be512325bd30a3a21773886ba5fa21917c71d13bc53b0977de4 SHA512 009189cd07c379641c9fa3b3af1df70c9e26b77bbb6d2443a78b56ff9895b4382e90a753db83f4a863fae5ef5765c660d2f82ef14ab6e74817bc83e7ea8ba6d3
EBUILD stomp-py-8.0.0.ebuild 1060 BLAKE2B 452fc19c202c1b439547811a6fe2d14634082f19535c4bfdeb85fca2b2efcabbcce4d1b2cb1a6abccb1fdeefd969a5a22b0ebcdaf4f75740f560cc85b393fb16 SHA512 d511761b4348a8ef292fea1bace34be4d25065d214bef9010778bfc824e2c4438b07b5a710bcc4bf6f3d5691f13fb4898ef5c2664ede2264c32e18ce9cfb5016
+EBUILD stomp-py-8.0.1.ebuild 1061 BLAKE2B 8f0c9d8fb9d0dd5c2389b8c42445d5f59e03c346d5c3f9addb42b9f8f70cd16dd31e888dfd6d53cece83505a1030b137742c46c1056ec2d103bc0c1d274c170c SHA512 20039328ab68d2b54fafc3a4b2de8206433d654947e1f5d845dcdacc05a16340f0a9ac2ab5d369104b5e2c3ca025e84318cddfbf8b4779a9514bb26a660aaf64
MISC metadata.xml 402 BLAKE2B 2cca58b54cd707a4c0db87e034f4e6387e9243aabe392cd0046d11b6d2074c57285798db5a81d7f3f6854a9a43436a193678d384ccde45af0552bc50b26e77ba SHA512 770aac685fa99c5e3a01bab4864d6af4c9c810ad52c4f8a2a0c32a4303f0e5e9a1573d7ad6220737e6fa4093c5a1430fb2a7765a151bcd5aa9925e059d5bed41
diff --git a/dev-python/stomp-py/stomp-py-8.0.1.ebuild b/dev-python/stomp-py/stomp-py-8.0.1.ebuild
new file mode 100644
index 000000000000..9b841f321106
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-8.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 7.0.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"