summaryrefslogtreecommitdiff
path: root/dev-python/stomp-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 16:01:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 16:01:10 +0000
commit724cccb689f2076a398ede6845749926c86ea647 (patch)
tree766c785a64ac7265adee059e793fc120be6c434f /dev-python/stomp-py
parent73ef00f9e2b100c7d0fedede11300940cc26670a (diff)
gentoo auto-resync : 27:02:2023 - 16:01:10
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/Manifest2
-rw-r--r--dev-python/stomp-py/stomp-py-8.1.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
index f129ced984ee..f4f1025152da 100644
--- a/dev-python/stomp-py/Manifest
+++ b/dev-python/stomp-py/Manifest
@@ -1,3 +1,5 @@
DIST stomp.py-8.0.1.tar.gz 35300 BLAKE2B 12209e99066fb5bb1f3015398f5eb27186322ce9d92feca46adc4d275aff1d5138908da69abe3be512325bd30a3a21773886ba5fa21917c71d13bc53b0977de4 SHA512 009189cd07c379641c9fa3b3af1df70c9e26b77bbb6d2443a78b56ff9895b4382e90a753db83f4a863fae5ef5765c660d2f82ef14ab6e74817bc83e7ea8ba6d3
+DIST stomp.py-8.1.0.tar.gz 39808 BLAKE2B c6efb19fbee81142f251c4bf4114b445878b81fa457260a306cb82ef5e9c57f0b75e3dc8cd6035676e688f1d33081cdf936ac6ccc0628819722849d60f4d8602 SHA512 7385842a23fbe6022c386489641948932e805430ce71c09079d9484fe17d02241ee705d92a1bcdf873eebcbacf68f44bbf884ea103c8963944b84758073fdac7
EBUILD stomp-py-8.0.1.ebuild 1060 BLAKE2B db1a0c5ebb663559f586be366455e0ced04006fd1e875dee24f985f739d904a4c46c60bdfd95a40df7aad245ba1ae7440274621a7fb0ad08553ae53ac668b2ae SHA512 c612d9e59cd891b8b0172e10ac0a6730e2af5e6d038f0561ab4f49ede7e1e04cb6396f3b024df37de0588959551462a9b840f2b0620bdffd8c8858bc0b82bfc6
+EBUILD stomp-py-8.1.0.ebuild 1062 BLAKE2B d59dd37b63dfafe477e2d3c8a0d1220629be64afd530680acf85a7a68e7f2af7b96d5e5955c5512e098532972abd1d2d214a07b827c11557eecca9712e6c20e0 SHA512 af5a0622c5ca21fef2531c6fa14b926439bd77f53d4c7f9075a19bff3a0b627b96f3f9c1ed929f61e66e4ef8a6e660307a0f26663bacb2ffcdf7ad4921169717
MISC metadata.xml 402 BLAKE2B 2cca58b54cd707a4c0db87e034f4e6387e9243aabe392cd0046d11b6d2074c57285798db5a81d7f3f6854a9a43436a193678d384ccde45af0552bc50b26e77ba SHA512 770aac685fa99c5e3a01bab4864d6af4c9c810ad52c4f8a2a0c32a4303f0e5e9a1573d7ad6220737e6fa4093c5a1430fb2a7765a151bcd5aa9925e059d5bed41
diff --git a/dev-python/stomp-py/stomp-py-8.1.0.ebuild b/dev-python/stomp-py/stomp-py-8.1.0.ebuild
new file mode 100644
index 000000000000..2aaf49e80681
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-8.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp.py/ https://github.com/jasonrbriggs/stomp.py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/docopt-0.7.0[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 7.0.0: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"