summaryrefslogtreecommitdiff
path: root/dev-python/stevedore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/stevedore
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/Manifest5
-rw-r--r--dev-python/stevedore/metadata.xml16
-rw-r--r--dev-python/stevedore/stevedore-1.25.1.ebuild63
-rw-r--r--dev-python/stevedore/stevedore-1.28.0.ebuild63
4 files changed, 147 insertions, 0 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
new file mode 100644
index 000000000000..22fe5cf72389
--- /dev/null
+++ b/dev-python/stevedore/Manifest
@@ -0,0 +1,5 @@
+DIST stevedore-1.25.1.tar.gz 509014 BLAKE2B 22580ac0e5af56eadd81e7521888e3b2458a1c03a3bdac69df1f2eeef20248f1ddc1748447e3e961b61cbe62ebc939e36c04ff011b7845b3278e18a5fdc9e14e SHA512 f3d2a7360e783c800c3c2488f6adf6f9f76e34e4a4e6f3fc53d2f1114b889c443c13fdf217ddce65a41922dda2c782f19b2077847807c70e732a522fd2166ff0
+DIST stevedore-1.28.0.tar.gz 504872 BLAKE2B 6a9ba88ab950f17898d2dd76d75cd7bc7031cbcf441523863520e15916bc5c255fe6a62444f46b6d9967ec1f5f716420b36cb114995907ec8e2c39110ae7918a SHA512 e148560e255a362a51ce91e8bc2380828ba9a41e1988138bcff2d5b270097cadffdee30f3c98e123d8ced9f6f0ff350b52e793fd400ce6b45095860788bd6b86
+EBUILD stevedore-1.25.1.ebuild 1636 BLAKE2B 685c396c184637dacf2ab5f13bb1234a9347ab6df0b1093fa2f185a3eba594f44190283efb8de7b1d291780a11a6893187b0934c9595e416bb00893080a64a18 SHA512 b92428ada4d52e67b464c912f142cef264d1317769301efb3e74290ec8c5c1e72a023b775cc112fb5a1d2333d7b687f875173fe8dc053441628ac7edf0ecc49e
+EBUILD stevedore-1.28.0.ebuild 1637 BLAKE2B 032c478729366045cc99ebc763e3874c7c9cf2f549536c94b0fcc98038c4b9f5836d31dc3deb0823f74a7aaa04efc1377b68e195be5bac5919b170ea9bf4352d SHA512 b7a66e1321d2bf79c2ee34905264e206bc1b16494b7cdad0120fcf7129e1d701c8af4185d5db31bd9acb6a6db890eb252d15c2f9d100f640de44cb7ef580d559
+MISC metadata.xml 496 BLAKE2B 4de4391203bfd30055b9b6399abeb5b53c2a363779c895d4e0efb1de2d929510a0d7e02541290000a63526d44d32d50ea7c41728a4ec1e5d6ab41a7ab57414b4 SHA512 569ee9efc45e2445b71ffe7201ea92a7bdae048de528664d2a908b94c3fb23f6632e2457623c5b0d961dcf7aac2d96c6385d225628a3c5234363159f56961f00
diff --git a/dev-python/stevedore/metadata.xml b/dev-python/stevedore/metadata.xml
new file mode 100644
index 000000000000..830af2ad2c64
--- /dev/null
+++ b/dev-python/stevedore/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">stevedore</remote-id>
+ <remote-id type="github">openstack/stevedore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stevedore/stevedore-1.25.1.ebuild b/dev-python/stevedore/stevedore-1.25.1.ebuild
new file mode 100644
index 000000000000..f483fe6392c9
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.25.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests --verbosity=3 stevedore || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/stevedore/stevedore-1.28.0.ebuild b/dev-python/stevedore/stevedore-1.28.0.ebuild
new file mode 100644
index 000000000000..b0bb405e07a0
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.28.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests --verbosity=3 stevedore || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}