summaryrefslogtreecommitdiff
path: root/dev-python/stestr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/stestr
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/stestr')
-rw-r--r--dev-python/stestr/Manifest4
-rw-r--r--dev-python/stestr/metadata.xml1
-rw-r--r--dev-python/stestr/stestr-2.1.0-r1.ebuild8
3 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/stestr/Manifest b/dev-python/stestr/Manifest
index 6b6b806bb0fb..aa8a585c73e4 100644
--- a/dev-python/stestr/Manifest
+++ b/dev-python/stestr/Manifest
@@ -1,3 +1,3 @@
DIST stestr-2.1.0.tar.gz 103501 BLAKE2B 6b000b8e3d0a27a18f19510dd8d5de8641223c18ad22a3f90b73619aa41bbe1a51bcedba604ec448282fa41e2ae93b61fdd0e72e603a39730a59400fc15ef007 SHA512 a99d0659da0ca2b86703529df9ef6d135578bd8374a2afcbd10bd96f24f5e6dd1dacd5929d96a083881f1db2a930b039d9045348a0298d84d2480c6c9a75d1f7
-EBUILD stestr-2.1.0-r1.ebuild 972 BLAKE2B f0416c0449e93986aab5f4ed2317dcecb593a7e1e7650dfb3e5ae1f204f6f7e3b2884846285b98ee437c4bbd3d4c0ea8141c1c2f5d19c41e2a3f50a9d31b645b SHA512 a466b6f52c0b25fca0b13804ef89263bd747473a3513bc2dcf3538320494e850a0e16a5d8e2d4de927b43acef64d9767941876ff76a41ca7929e2fff6594a972
-MISC metadata.xml 615 BLAKE2B 59ec048ea712845ca6de6e55aa4ca514da16e6c6387ce2324effc9e6eb82d99aa5d3601914fe78398fcc83be14c752a1ff4e546f36746f8711e36aaf4cdc2846 SHA512 d13186ab5353fe9b9310ed047a828b65f179b173c7c220fbaba5a80e36bda817dd44ccaeb4a9272b342de6246e44ead8d959fdc7a4b4e7f00c52848eb0a613c5
+EBUILD stestr-2.1.0-r1.ebuild 961 BLAKE2B 10cd7f9efa5ccfca094964922f35f425df8476b20140d640f7d1307c41e178b247a6017b7a5a15bd51b5641831b74e5d25db6ac02b6aa9c29479dc66f32b558f SHA512 b931a6ae6b2b3becb60bfa7ff6053c1f3b62cb47c9b1a94eb4b1fecb05a29adc100592c96d0030f1c7a7fd780298ae0a1ffaba63233ae8320e7023ad27b22d87
+MISC metadata.xml 639 BLAKE2B 1a1ae7ac17a9cd8b64fc394ea8d4aede9f7ed1d8142c22eaa88e6315feeeb48e70c074e021dfc8115fce3a8e1b70d0a7739f66e9021e648609d5244548e42f2f SHA512 bcce81b4b21946c4762b334086ba5b72b899f02731de74cfc9bf6a6890bdb0211c7346adb76bc7dbee8edd200392584a1a29bdd5eb6722be1b8a13aeab734533
diff --git a/dev-python/stestr/metadata.xml b/dev-python/stestr/metadata.xml
index 9eb8d3adbf9f..87444612cbdb 100644
--- a/dev-python/stestr/metadata.xml
+++ b/dev-python/stestr/metadata.xml
@@ -8,6 +8,7 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
+ <stabilize-allarches/>
<longdescription lang="en">
stestr is a fork of testrepository that concentrates on being a dedicated test runner for python projects
</longdescription>
diff --git a/dev-python/stestr/stestr-2.1.0-r1.ebuild b/dev-python/stestr/stestr-2.1.0-r1.ebuild
index 420e4cdb2d60..17c04bb67e58 100644
--- a/dev-python/stestr/stestr-2.1.0-r1.ebuild
+++ b/dev-python/stestr/stestr-2.1.0-r1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="A parallel Python test runner built around subunit"
@@ -14,10 +14,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
>=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.18.0[${PYTHON_USEDEP}]