summaryrefslogtreecommitdiff
path: root/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-31 15:23:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-31 15:23:38 +0100
commita407e25d814596ca802d83102671d95e00079767 (patch)
treeb0d4824cf74ddca3ee380c618ffae855cd0d1bcd /dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild
parent441510fa20665b7920b149994e72b3a1cd62a813 (diff)
gentoo auto-resync : 31:05:2023 - 15:23:38
Diffstat (limited to 'dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild')
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..b6ac9b7058fc
--- /dev/null
+++ b/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Context manager for mocking/wrapping stdin/stdout/stderr"
+HOMEPAGE="
+ https://github.com/bskinn/stdio-mgr/
+ https://pypi.org/project/stdio-mgr/
+"
+SRC_URI="
+ https://github.com/bskinn/stdio-mgr/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+# doc directory is not included in the release tarball for some reason
+#distutils_enable_sphinx doc \
+# dev-python/sphinxcontrib-programoutput \
+# dev-python/sphinx-rtd-theme
+
+python_test() {
+ # skip the doctests
+ epytest tests
+}