summaryrefslogtreecommitdiff
path: root/dev-python/statsmodels
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-17 12:11:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-17 12:11:34 +0100
commit7be9edf526114e427a3a44ff8b418fed3ce570aa (patch)
treee256d444d8a1676de0d3a7379c8422732f39fc0f /dev-python/statsmodels
parentb66ecfb4dc09ba76e37787df2f7df1a78c3c1cc9 (diff)
gentoo auto-resync : 17:09:2024 - 12:11:34
Diffstat (limited to 'dev-python/statsmodels')
-rw-r--r--dev-python/statsmodels/Manifest2
-rw-r--r--dev-python/statsmodels/statsmodels-0.14.3.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/statsmodels/Manifest b/dev-python/statsmodels/Manifest
index 6c9d07207fd9..b6d6b073f45b 100644
--- a/dev-python/statsmodels/Manifest
+++ b/dev-python/statsmodels/Manifest
@@ -1,3 +1,5 @@
DIST statsmodels-0.14.2.tar.gz 20352531 BLAKE2B 65053842ab979b6c2541baddc09f9ade4f55ca988451218b2e4fd2caf7af0e7891eaccf317e9715f35c3d002f8976ea637712173d58db1b5b7822658bdfc79dd SHA512 0a38482bccac61081ff0c8de3b9fcf81689ec15437c53d79a8949df058e0ac8a4e93136a50a37a06577108dc29f1a51e0d00e041ee7e8f9dff93b6e8cf1f0f16
+DIST statsmodels-0.14.3.tar.gz 20354488 BLAKE2B 113e90f7091197a5561e311bc033dfc3d9d28732fbcbae4fce13ec58f16db63ec1e25c54e411a8ff04d059f3f2df7c45dc484918235653df4d1f809cc40260af SHA512 c7b8684be83b179edcdbed7703005d054a1f16b9731add69b5079a62e5e858bef87c34e00575580fd48ef80cc9108d405edec9e6a2cf3eb3e5e8f7fed53f8fca
EBUILD statsmodels-0.14.2.ebuild 2088 BLAKE2B b764919d239a7855d042c89d926aa3dcaf6a79b130ca982d6bc55a91361d5b81427bfc30554a39454b882f9e669c4feb165a0a9b49a6bc685f97ec58b7dc2b8d SHA512 bc9914039d685ceb26daa3dd08b86855a4c5174615e8da060822f65853040dc756a345e893732e0fbc04599e3adae47d46eacbdce22c8a1d56433b10f89d6032
+EBUILD statsmodels-0.14.3.ebuild 1744 BLAKE2B cba9ba788adb2f0215a901cec3ae77581f20056d36532c2daff0a8e89ccca734e5341909921810d058823a04683cb838be6c4cbf0a01eb1bfa796f92ce0df261 SHA512 7d84207342cc2e64ee9629a24c1d27ca87f93b2c8ad20d3462b51b343799d1d46ea9487b4a2ceaa2188b2cbaa55bbf8badb029f2e66eda7948754cf93ac71f4c
MISC metadata.xml 1088 BLAKE2B 285d326203e509fd04364777ffe96f085951fdb7be661e6773f329392c0fa0fc16b1527239586b3abb80458359d15ab00d5eb402b739f947b78dca612ede94ca SHA512 35192e332c6d2aecd1ac611a96ebb13cded9a8f8bdfdd7f0c10b50654d1dda411015444511a69643ee8450742c8f02f5e0bfc5e4ab4ef4da81ffce9231658f4f
diff --git a/dev-python/statsmodels/statsmodels-0.14.3.ebuild b/dev-python/statsmodels/statsmodels-0.14.3.ebuild
new file mode 100644
index 000000000000..c17f1ee501b8
--- /dev/null
+++ b/dev-python/statsmodels/statsmodels-0.14.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Statistical computations and models for use with SciPy"
+HOMEPAGE="
+ https://www.statsmodels.org/stable/index.html
+ https://github.com/statsmodels/statsmodels/
+ https://pypi.org/project/statsmodels/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~amd64-linux"
+IUSE="examples"
+
+DEPEND="
+ >=dev-python/numpy-1.22.3[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.8[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/patsy-0.5.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-3.0.10[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-scm-8[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/ipykernel' \
+ 'dev-python/jupyter-client' \
+ 'dev-python/matplotlib' \
+ 'dev-python/nbconvert' \
+ 'dev-python/numpydoc'
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export VARTEXFONTS="${T}"/fonts
+ export MPLCONFIGDIR="${T}"
+ printf -- 'backend : Agg\n' > "${MPLCONFIGDIR}"/matplotlibrc || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x MKL_NUM_THREADS=1
+ local -x OMP_NUM_THREADS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest statsmodels
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Plotting functionality" "dev-python/matplotlib"
+}