summaryrefslogtreecommitdiff
path: root/dev-python/statistics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/statistics
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/statistics')
-rw-r--r--dev-python/statistics/Manifest4
-rw-r--r--dev-python/statistics/metadata.xml16
-rw-r--r--dev-python/statistics/statistics-1.0.3.5.ebuild21
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/statistics/Manifest b/dev-python/statistics/Manifest
new file mode 100644
index 000000000000..31f3eaa121bd
--- /dev/null
+++ b/dev-python/statistics/Manifest
@@ -0,0 +1,4 @@
+DIST statistics-1.0.3.5.tar.gz 8303 SHA256 2dc379b80b07bf2ddd5488cad06b2b9531da4dd31edb04dc9ec0dc226486c138 SHA512 1d7fd2304a885dbd9ebc564323349f9c5ad1ea1ecea8182b52a1f42308963bd49f07c9dc9f0b87a35d2f6ed3c37429dbc38183c0b1bd65a527558e4504a9a3a0 WHIRLPOOL ce4b7309119da0eaa2a01678ce2b7e048fc895b82d31ec12e4b28371fa6c5e928537433d05afddc10a9f01434ba5be072bb52bd70fe7f724f12c55c25d85f852
+EBUILD statistics-1.0.3.5.ebuild 543 SHA256 71c4a03518b7579e1f1d9030ebd3a669b3108080cbf77091d3ca485ad0eabd5f SHA512 1cc0eafa7bb5b0c2896e2b6257b53b889eb004a07023e9ddd0181312cdd6031dcbaef954012fe5c43d9a905728a3942d5546113a8a28da4a39299254e249b0ea WHIRLPOOL 5e22a93bf49372c7024babb32cd8cb4d511e27ef94bbb5983ff0572c0c2214c276556d221b15fa1b2d946c6c34660824174169fe40c5800cd389d3fcc08d4329
+MISC ChangeLog 1586 SHA256 f93e33e01d6935d9be70478e84742f2e5308124102fc73e3d639ce7028866a82 SHA512 3845056140804236fd1830ce7e9479247278b6db0b55db918510b7384da06e8a21ac3700c94502807a93c2fab0b6c2d8016b2f8a3cc3b8c2ef1ef26d87481e80 WHIRLPOOL 5fa99eceaad26fbcd00e5d8bd5da31b06c9acfe6a2e658fc2f6c74fcea3700109f52c56c0c259852039b8f45cbef8991c5594ee0390197f5d6c83680e23171ab
+MISC metadata.xml 527 SHA256 e2a7e6583eea50055e58ff184833f98032cff6be99d16860d9a9d02932817e79 SHA512 a8a996bf135883825f9857cbb3a8608a1f340bdb32393b7438fa863c617fea26ce0ef05e2985b2bd763a73aaed9a7c565a7b789e98bdc231831b1b315fca0251 WHIRLPOOL ec6fb3f2280cddeabcdbe35a6be06c1409e9cfa87ced6321c3abe219563b722b11e0c4728902e5a4f18b2d1e90d8c2541bad2ac32b114a2c32faf9f87ea3ce67
diff --git a/dev-python/statistics/metadata.xml b/dev-python/statistics/metadata.xml
new file mode 100644
index 000000000000..41bf24bdbdc8
--- /dev/null
+++ b/dev-python/statistics/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">statistics</remote-id>
+ <maintainer status="unknown">
+ <email>stefano@digitalemagine.com</email>
+ <name>Stefano Crosta</name>
+ </maintainer>
+ <remote-id type="github">digitalemagine/py-statistics</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/statistics/statistics-1.0.3.5.ebuild b/dev-python/statistics/statistics-1.0.3.5.ebuild
new file mode 100644
index 000000000000..059465ec6f49
--- /dev/null
+++ b/dev-python/statistics/statistics-1.0.3.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python 2.* port of 3.4 Statistics Module"
+HOMEPAGE="https://github.com/digitalemagine/py-statistics http://pypi.python.org/pypi/statistics"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"