summaryrefslogtreecommitdiff
path: root/dev-python/starlette/starlette-0.28.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-08 09:45:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-08 09:45:00 +0100
commitcfeee79886441e92c8ee094e45b9bcdc9c79137a (patch)
treeff20e0f6c0b9bd4497479556467cc3a53dd1dd4b /dev-python/starlette/starlette-0.28.0.ebuild
parent0d7ae8c4b021f0ea675d5bc81389c5d159a197fa (diff)
gentoo auto-resync : 08:06:2023 - 09:45:00
Diffstat (limited to 'dev-python/starlette/starlette-0.28.0.ebuild')
-rw-r--r--dev-python/starlette/starlette-0.28.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/starlette/starlette-0.28.0.ebuild b/dev-python/starlette/starlette-0.28.0.ebuild
new file mode 100644
index 000000000000..11703340a66f
--- /dev/null
+++ b/dev-python/starlette/starlette-0.28.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest