summaryrefslogtreecommitdiff
path: root/dev-python/ssl-fetch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/ssl-fetch
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/ssl-fetch')
-rw-r--r--dev-python/ssl-fetch/Manifest4
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.4.ebuild17
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-9999.ebuild22
3 files changed, 11 insertions, 32 deletions
diff --git a/dev-python/ssl-fetch/Manifest b/dev-python/ssl-fetch/Manifest
index 70bb63eae5c6..b48fb4ae1805 100644
--- a/dev-python/ssl-fetch/Manifest
+++ b/dev-python/ssl-fetch/Manifest
@@ -1,4 +1,4 @@
DIST ssl-fetch-0.4.tar.gz 11663 BLAKE2B c75173f40367d1e84a0ed3e13dbc7e6b8270302bf64168487061195cd1d24a593630ca650bfac4ed867d4146e8bad438cac8bfecca86180d2ca23d9ccafa9e5d SHA512 6b31a5dc5d3a566eded6ca284a3edac8c308596dd5a1971d13223e55abdd2ddc4d3e1eca5f369c1c05540bafcb6c273e5ef1eae627a7a9170bc262a0cda06696
-EBUILD ssl-fetch-0.4.ebuild 1021 BLAKE2B 24db9087a806455815d57ed8d43600508ae299f27f49859f149c8183f30fb2c78a334a01bbedec4a85e0ed04ea73bb93a6a6ee608202c9224547c07033d62615 SHA512 fc28598fdf787ec37f4969c05f18fd40e3facd01fb14e60d6ebbcdce9f9aed2a455184e4b4bb459a0296de8e976b50aff63b91a82922004b4ecb3f76b2964b73
-EBUILD ssl-fetch-9999.ebuild 912 BLAKE2B ffb3b3a8e810e4ecaba4c80b6644de26dc8280d9cd3479a7ead201bc0ca1dbcd60706db9658bfd0df22c6f0481154cc6d7f4b7b25fe55cd8f030f507692141dd SHA512 7ebf7b73a65d63484e13724475deaa0a894aa3f389ea3627a012b3263dbc46fbd921790b0237ee7dfb61ba75adb344581f476de6442c7894af32d256ca9937cb
+EBUILD ssl-fetch-0.4.ebuild 974 BLAKE2B 59de43e3b2caa52cfa502ffe7ff47d25b4a3ba208773a3bce6fd6b47e5e932dbe2318851106c52f4a2c950ea07f465dad69dbcddb7066637598495c8883c2dd2 SHA512 b15515a9b3c2f723bd670fd49dc8ff1c8b2f959aba3df7b0a2699f05a114e25d07fa47dad91c5d3d552c82fed3097dbebdc00110050a7d77d5ae1df28bbb8284
+EBUILD ssl-fetch-9999.ebuild 831 BLAKE2B 7d53d1b0c05693ef7bc4dac9db80e37eb63c40d8e69ffe2f81a73be013171df2436736fcfd62283ec4d960679b5ce3cafacbebc047063590fc95dc862eac98a2 SHA512 1d858c5673e991906353d9e7bde8a4c4904494e02f0138c4e55e085c80aa0a245ae9393a930cea8291e8c7c68983f4817fa756cb9662d58fd6d550265b891a5e
MISC metadata.xml 358 BLAKE2B 7ffc5faf4b9819e2ea71b0e239205b95a9b3764c2fe7a5ce8fadedbdd4130fd83780a89ab790106cd353a0b92ccaeb63276bfaf8f993f97c751b7edf79043178 SHA512 5d94fbf0a6a28bd26bef445e216b8377b2ae116273644bc2fc930258ebcd0d0c59583de63726c9f0769a1d26e66dcb31d51a5237b2b2088ec11ef9aa4523573f
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
index 272b24e50d19..8c37254d9a30 100644
--- a/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
+++ b/dev-python/ssl-fetch/ssl-fetch-0.4.ebuild
@@ -1,31 +1,23 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
DISTUTILS_USE_SETUPTOOLS=no
-
inherit distutils-r1
-DESCRIPTION="A small convenience library for fetching files securely"
+DESCRIPTION="Small convenience library for fetching files securely"
HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
SRC_URI="https://dev.gentoo.org/~dolsen/releases/ssl-fetch/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
-
-DEPEND=""
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
-RDEPEND="${DEPEND}
- >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
- "
+RDEPEND=">=dev-python/requests-1.2.1[${PYTHON_USEDEP}]"
pkg_postinst() {
- echo
elog "This is beta software."
elog "The APIs it installs should be considered unstable"
elog "and are subject to change in these early versions."
@@ -33,5 +25,4 @@ pkg_postinst() {
elog "Please file any enhancement requests, or bugs"
elog "at https://github.com/dol-sen/ssl-fetch/issues"
elog "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the Freenode network"
- echo
}
diff --git a/dev-python/ssl-fetch/ssl-fetch-9999.ebuild b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
index b19832d73841..97b36ef91545 100644
--- a/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
+++ b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
@@ -1,40 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
DISTUTILS_USE_SETUPTOOLS=no
-
-EGIT_BRANCH="master"
-
inherit distutils-r1 git-r3
-DESCRIPTION="A small convenience library for fetching files securely"
+DESCRIPTION="Small convenience library for fetching files securely"
HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
-SRC_URI=""
EGIT_REPO_URI="https://github.com/dol-sen/ssl-fetch.git"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
KEYWORDS=""
-DEPEND=""
-
-RDEPEND="${DEPEND}
- >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
- "
+RDEPEND=">=dev-python/requests-1.2.1[${PYTHON_USEDEP}]"
pkg_postinst() {
- echo
elog "This is experimental software."
elog "The APIs it installs should be considered unstable"
elog "and are subject to change."
- echo
+ elog
elog "Please file any enhancement requests, or bugs"
elog "at https://github.com/dol-sen/ssl-fetch/issues"
elog "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the freenode network"
- echo
}