summaryrefslogtreecommitdiff
path: root/dev-python/sshpubkeys
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-08 22:21:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-08 22:21:23 +0000
commit4f8c8df3b07b6ea3556ab2bc7b252213bbdab3f3 (patch)
treeda90388e25f27949d16131813690edb36c53aa81 /dev-python/sshpubkeys
parent413ca4e6c2089d8b5e0844c26cf5671209226b93 (diff)
gentoo auto-resync : 08:11:2023 - 22:21:23
Diffstat (limited to 'dev-python/sshpubkeys')
-rw-r--r--dev-python/sshpubkeys/Manifest4
-rw-r--r--dev-python/sshpubkeys/metadata.xml17
-rw-r--r--dev-python/sshpubkeys/sshpubkeys-3.3.1-r1.ebuild32
-rw-r--r--dev-python/sshpubkeys/sshpubkeys-3.3.1.ebuild31
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/sshpubkeys/Manifest b/dev-python/sshpubkeys/Manifest
new file mode 100644
index 000000000000..ebfbcc15cd82
--- /dev/null
+++ b/dev-python/sshpubkeys/Manifest
@@ -0,0 +1,4 @@
+DIST python-sshpubkeys-3.3.1.gh.tar.gz 57896 BLAKE2B 3212ea0c38377255258a831cc942f71c0b0efb040ba8ca3283200b638dcae7a31ad5763ae0de4f51a7ae0c3f0a1b83ca6db96f00384ecd1e1e3a369028e4ed41 SHA512 8a59e73eddd795a71b64fc7433292ca03a9f447a13c8ef40d68fc599776c37f5e4a1fdbbf2f2ab00b0091a513e2412f213f6a21474ae0784af2df9a7107a2ed6
+EBUILD sshpubkeys-3.3.1-r1.ebuild 700 BLAKE2B fa830aed4be06a4140fb247719e4310a4bb276d40045b848674fd6e30358d1f8ef1381d03b84e1e03275071c493350c269362faee11529622001ea09db9c5ece SHA512 552b78c5135b97d8672d2b2f6548b73e7e7951a10278d8cfd2ce4d4c260ed49ca32038ef3f430cb107576650774b72f4788323a85812c5b7c02f3d3aee7cdc26
+EBUILD sshpubkeys-3.3.1.ebuild 666 BLAKE2B faf060513b93d37325f35c5d33a6a9ab572c3ea7001170bae7ea56f4d138db0fe3d861e3c9be778341e371df0b4c72c1ff653995d1b664d53ebfd1b13444e651 SHA512 22552fa48bcc952e6fb68924a03a7f2cf75d6c7ba0d0d6386de7f2dfe696eecb801e3e1f23f0cfe077a2a2b79e6f13231a26ff8c9cf3f9f62ad373828c755507
+MISC metadata.xml 512 BLAKE2B 89b935c91163ef432c76b498b4d0a2d49c64c2d5f2f6af891c6f6c6e3a0479fc56d3b9947860f5dc6ebd07d5fea9bdb3f526226cf1b4af64a3b9097007bd08e2 SHA512 5d5dfdec492614ceccb2ac84a67f7f0db3dd5979d811e8ecf9e9d87df6334d490fb345c75ca5e4846a2f98dcb8dc5bc12ad1679b29d95040477e0f327e6da07f
diff --git a/dev-python/sshpubkeys/metadata.xml b/dev-python/sshpubkeys/metadata.xml
new file mode 100644
index 000000000000..7ddc300d2654
--- /dev/null
+++ b/dev-python/sshpubkeys/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">sshpubkeys</remote-id>
+ <remote-id type="github">ojarva/python-sshpubkeys</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sshpubkeys/sshpubkeys-3.3.1-r1.ebuild b/dev-python/sshpubkeys/sshpubkeys-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..a783abdfd1be
--- /dev/null
+++ b/dev-python/sshpubkeys/sshpubkeys-3.3.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-sshpubkeys-${PV}
+DESCRIPTION="OpenSSH public key parser for Python"
+HOMEPAGE="
+ https://pypi.org/project/sshpubkeys/
+ https://github.com/ojarva/python-sshpubkeys/
+"
+SRC_URI="
+ https://github.com/ojarva/python-sshpubkeys/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/sshpubkeys/sshpubkeys-3.3.1.ebuild b/dev-python/sshpubkeys/sshpubkeys-3.3.1.ebuild
new file mode 100644
index 000000000000..a73c8439e522
--- /dev/null
+++ b/dev-python/sshpubkeys/sshpubkeys-3.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=python-sshpubkeys-${PV}
+DESCRIPTION="OpenSSH public key parser for Python"
+HOMEPAGE="
+ https://pypi.org/project/sshpubkeys/
+ https://github.com/ojarva/python-sshpubkeys/
+"
+SRC_URI="
+ https://github.com/ojarva/python-sshpubkeys/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest