summaryrefslogtreecommitdiff
path: root/dev-python/ssh2-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/ssh2-python
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/ssh2-python')
-rw-r--r--dev-python/ssh2-python/Manifest2
-rw-r--r--dev-python/ssh2-python/ssh2-python-0.27.0.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ssh2-python/Manifest b/dev-python/ssh2-python/Manifest
index a4eaa83c78b5..41e91f5fd6c5 100644
--- a/dev-python/ssh2-python/Manifest
+++ b/dev-python/ssh2-python/Manifest
@@ -1,3 +1,5 @@
DIST ssh2-python-0.26.0.tar.gz 1147243 BLAKE2B 56ee98fa8694d6c9e0c163ec0200c96d8330172c0ae4612f40805ac26da02c7cf64fd4dd49841733c36ed7112c62baa036c901a9ef74a33a92a3d8dc66dc27cb SHA512 35f1a5486bc54bf2242d5b1d2fa24bd5365ffa864a8ae0f4a9f8d96f155ba0877e7dafdf87ea9988b146d8a36c203e44ca9a36a83a5060568bf798468e4a8116
+DIST ssh2-python-0.27.0.tar.gz 1146845 BLAKE2B 18512ca23da628ab9f590cd796ee38522116b133ad537b868893276b083b53ca3647b05e47585a26cc667d39b6f796cfae31f1a8cb29d74fe185e8b837453612 SHA512 f215fa11a99c58350d832680ebd1b96cb9e4b4f90621737595c526af083403379b3529361dbfea6ede40c911c267fa2a6d49becfdc55f5604b9a9f903d6d6208
EBUILD ssh2-python-0.26.0.ebuild 553 BLAKE2B 57be3faa26e8e0c0d701006e1d0e0ae3a99ac45dcc6edd5a883ffd7ab806765654190e35e7d578586f96274378591edbf686fcee7c45e59dac285163fa0ac7d5 SHA512 8540f0c62bd1c390144156dc0e35f87e94d3eef4e084d7bffd2f1b99a6997c8b36899d3b64fa8be6695869b01c476207d4957424ae7c36885aa99bbda054d53e
+EBUILD ssh2-python-0.27.0.ebuild 554 BLAKE2B 0320940c8908a4f7ff9b4329e33a90c1b98a1d0d376e5dcd225fcef54590601c747497c781c53652cde7edd6f1595244d7abde3ce28c1af183b3f61a5677f1f7 SHA512 882a4d2102b78010e3af6b24dbc8af2b916d15506c56c49c1c2b4354739434bf5d4ed5d9435907c0f80049890634f5970dfd8c4c4bd994df39beee2922f66178
MISC metadata.xml 390 BLAKE2B 16662f7900956299c0c2c315542447d56f459909eb48abcc718161eec0240cb8f0e98f870d0a4d18938fba7a6cff5ba47850ad7cb431517289a885aec8ab178c SHA512 f4c93eb1e6adf1d7fc855dffa8298a84d7005a465aa11762439185a28ddaccf7076005c7253423fc2d9ff88aee1d358548b23ca4f9b9768c162a70cc2aad828f
diff --git a/dev-python/ssh2-python/ssh2-python-0.27.0.ebuild b/dev-python/ssh2-python/ssh2-python-0.27.0.ebuild
new file mode 100644
index 000000000000..88f071e99186
--- /dev/null
+++ b/dev-python/ssh2-python/ssh2-python-0.27.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Super fast SSH2 protocol library, Python bindings for libssh2"
+HOMEPAGE="https://pypi.org/project/ssh2-python/"
+SRC_URI="https://github.com/ParallelSSH/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-libs/libssh2
+ dev-libs/openssl
+ sys-libs/zlib
+"
+python_configure_all() {
+ export SYSTEM_LIBSSH2=1
+}