summaryrefslogtreecommitdiff
path: root/dev-python/ssh2-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-python/ssh2-python
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-python/ssh2-python')
-rw-r--r--dev-python/ssh2-python/Manifest3
-rw-r--r--dev-python/ssh2-python/metadata.xml12
-rw-r--r--dev-python/ssh2-python/ssh2-python-0.26.0.ebuild24
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ssh2-python/Manifest b/dev-python/ssh2-python/Manifest
new file mode 100644
index 000000000000..68fe33e5d001
--- /dev/null
+++ b/dev-python/ssh2-python/Manifest
@@ -0,0 +1,3 @@
+DIST ssh2-python-0.26.0.tar.gz 1147243 BLAKE2B 56ee98fa8694d6c9e0c163ec0200c96d8330172c0ae4612f40805ac26da02c7cf64fd4dd49841733c36ed7112c62baa036c901a9ef74a33a92a3d8dc66dc27cb SHA512 35f1a5486bc54bf2242d5b1d2fa24bd5365ffa864a8ae0f4a9f8d96f155ba0877e7dafdf87ea9988b146d8a36c203e44ca9a36a83a5060568bf798468e4a8116
+EBUILD ssh2-python-0.26.0.ebuild 553 BLAKE2B 57be3faa26e8e0c0d701006e1d0e0ae3a99ac45dcc6edd5a883ffd7ab806765654190e35e7d578586f96274378591edbf686fcee7c45e59dac285163fa0ac7d5 SHA512 8540f0c62bd1c390144156dc0e35f87e94d3eef4e084d7bffd2f1b99a6997c8b36899d3b64fa8be6695869b01c476207d4957424ae7c36885aa99bbda054d53e
+MISC metadata.xml 389 BLAKE2B 9365533a01689688c64ce8a0f1b5a54ec1461293169e1efca0a8c9d77d4346a3f0483afa904374da4c5a77fc896d196097c33ba940ad2c8341b4bf7c6521672f SHA512 914831b72c7f5ad13918c78fae9c79ea5389209ceef69f9f7d1f43f66d34eba4038772df58d8864e45e8c07d0a708ac903442703be09dbade160bdae3f7d83c1
diff --git a/dev-python/ssh2-python/metadata.xml b/dev-python/ssh2-python/metadata.xml
new file mode 100644
index 000000000000..e796b5cdc6d1
--- /dev/null
+++ b/dev-python/ssh2-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slashbeast@gentoo.org</email>
+ <name>Piotr Karbowski</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ParallelSSH/ssh2-python</remote-id>
+ <remote-id type="pypi">ssh2-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ssh2-python/ssh2-python-0.26.0.ebuild b/dev-python/ssh2-python/ssh2-python-0.26.0.ebuild
new file mode 100644
index 000000000000..c23977ec892d
--- /dev/null
+++ b/dev-python/ssh2-python/ssh2-python-0.26.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Super fast SSH2 protocol library, Python bindings for libssh2"
+HOMEPAGE="https://pypi.org/project/ssh2-python/"
+SRC_URI="https://github.com/ParallelSSH/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-libs/libssh2
+ dev-libs/openssl
+ sys-libs/zlib
+"
+python_configure_all() {
+ export SYSTEM_LIBSSH2=1
+}