summaryrefslogtreecommitdiff
path: root/dev-python/srt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-15 12:27:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-15 12:27:33 +0100
commit868fd5dc8aab84930cfaa5252b8be06b35552765 (patch)
tree0c0cebf818c30c6f871f00ce1e7599775a7e561c /dev-python/srt
parentf7adcd4ee556b2c3a420239c13fb74113d791f6a (diff)
gentoo auto-resync : 15:07:2024 - 12:27:33
Diffstat (limited to 'dev-python/srt')
-rw-r--r--dev-python/srt/Manifest3
-rw-r--r--dev-python/srt/metadata.xml17
-rw-r--r--dev-python/srt/srt-3.5.3.ebuild27
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/srt/Manifest b/dev-python/srt/Manifest
new file mode 100644
index 000000000000..d4841c187f21
--- /dev/null
+++ b/dev-python/srt/Manifest
@@ -0,0 +1,3 @@
+DIST srt-3.5.3.tar.gz 28296 BLAKE2B 97f8852a799e80401f09219b43b41f5d5f9fe2c7283e2b43312aef70d783d7f1c1bf126e076c3a13c10e74e80ff48f25075cc7a1cef58a99fb4ef32cfa5b2587 SHA512 434331d31763a339ebb7d5b335b9d924b7f6939f307ecd0e5476b91da19b39e0febf1a387199e22f0b15365a4305c24021d85a32a7b65058905abd7946865b70
+EBUILD srt-3.5.3.ebuild 551 BLAKE2B 0f3ec1c236d87654f2775f7921173f1fcb05e33c83d137f2baa5d0cddf3c253a9ba78cee5a422e1572b965ce11e3b83e704f722ea8ae981c92166a1ec51234eb SHA512 35e27c3f1c797e23ecd7b615c715a45a8cbb3bbf55e4a515b3680aba06e7c449b6b59df0228dc56a1eec27e7b2e6eb5479a4472428114cdf8025ba8d323d86f9
+MISC metadata.xml 480 BLAKE2B de786aa2dcd85a411346af80239855b35d3baad79af67135131826b38d4d3db623e070069d968093386b4f16bb68d990542d80fa5e696f4e3dae27f05d7592cd SHA512 aa39bd739ebda8c338376f637d917cac19b3a623b7d9dc62497440e839b99fe8726da08fd9f8139f2a45b0da3456d4706b394d5ce1f1b5b4133b7207b6607e6a
diff --git a/dev-python/srt/metadata.xml b/dev-python/srt/metadata.xml
new file mode 100644
index 000000000000..a65eb5db742c
--- /dev/null
+++ b/dev-python/srt/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">srt</remote-id>
+ <remote-id type="github">cdown/srt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/srt/srt-3.5.3.ebuild b/dev-python/srt/srt-3.5.3.ebuild
new file mode 100644
index 000000000000..4e91e103862c
--- /dev/null
+++ b/dev-python/srt/srt-3.5.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tiny library for parsing, modifying, and composing SRT files"
+HOMEPAGE="
+ https://github.com/cdown/srt
+ https://pypi.org/project/srt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="!dev-python/pysrt"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest