summaryrefslogtreecommitdiff
path: root/dev-python/sqlite3dbm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sqlite3dbm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sqlite3dbm')
-rw-r--r--dev-python/sqlite3dbm/Manifest3
-rw-r--r--dev-python/sqlite3dbm/metadata.xml11
-rw-r--r--dev-python/sqlite3dbm/sqlite3dbm-0.1.4-r1.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/sqlite3dbm/Manifest b/dev-python/sqlite3dbm/Manifest
new file mode 100644
index 000000000000..c19fecc4fc38
--- /dev/null
+++ b/dev-python/sqlite3dbm/Manifest
@@ -0,0 +1,3 @@
+DIST sqlite3dbm-0.1.4-git.tar.gz 18962 BLAKE2B 464c6b7f295969e507249e8a20527a44b25e77868e6a59c7387e7a1eefc77c0fcc521cc6f425b1dfc27afbd9f73f31f375228ba6e2201276da0175c7f78ff556 SHA512 1b420839482cf5881b744855393afa9eaa1cd0ea2195d03c6576f97804851dcfa5b5fe6a80d9d77eb00b9ee49ebb7cdb7ba7b86f57e4c700178a0bf46d598bab
+EBUILD sqlite3dbm-0.1.4-r1.ebuild 969 BLAKE2B 34d26ba96b9bbbe65f54c2ce62959193ba4261dc27718bc1d7a08720bbdf634c368b5fb45a7e72ffd2b9a8caed43b4753111088599edfe67450ad0b5d07ddebd SHA512 07e6277563c6462d3e6afd23bf974e36ba179c5bbc41f3ea39bc771bdbff070143ef8b4a93f55c88d87ec31bd2e92403853a419ab24f79a7422d99bd5db4c3c5
+MISC metadata.xml 330 BLAKE2B 7794213f637f2f801569bf46389da327ccaab742e5a5726732bf5c34dae0a7c4a40918e37ebbc7faaebad00ea1b34ebec81e0e1e8dbf1d59f13e83e4ee87002e SHA512 77d26c5ca1d907bc82caff2060b73ebf58d4de60466e2415a8a4f1010653865a573aad75a76a0f610b3ab7af738efdc592a0031e0f523f78560075d47f566809
diff --git a/dev-python/sqlite3dbm/metadata.xml b/dev-python/sqlite3dbm/metadata.xml
new file mode 100644
index 000000000000..26e280528171
--- /dev/null
+++ b/dev-python/sqlite3dbm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yelp/sqlite3dbm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sqlite3dbm/sqlite3dbm-0.1.4-r1.ebuild b/dev-python/sqlite3dbm/sqlite3dbm-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..d5abe83b6cb1
--- /dev/null
+++ b/dev-python/sqlite3dbm/sqlite3dbm-0.1.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+# TODO: strip the -git at some version bump, introduced to avoid clash with
+# earlier tarball
+DESCRIPTION="An sqlite-backed dictionary"
+HOMEPAGE="https://github.com/Yelp/sqlite3dbm https://pypi.org/project/sqlite3dbm/"
+SRC_URI="https://github.com/Yelp/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/testify[${PYTHON_USEDEP}] )"
+
+DOCS=(AUTHORS.txt CHANGES.txt README.md)
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+src_test() {
+ testify tests || die
+}