summaryrefslogtreecommitdiff
path: root/dev-python/sqlglot/sqlglot-19.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-02 09:45:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-02 09:45:46 +0000
commita0c5e9067531830baf9160de325fe77145f02987 (patch)
tree7eaa500d69f3cea4dfb749d1c6e2eca49b71353f /dev-python/sqlglot/sqlglot-19.0.2.ebuild
parentfd0a8825115ac9a61ceee1d37c0fdf4fd2e95b5f (diff)
gentoo auto-resync : 02:11:2023 - 09:45:46
Diffstat (limited to 'dev-python/sqlglot/sqlglot-19.0.2.ebuild')
-rw-r--r--dev-python/sqlglot/sqlglot-19.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sqlglot/sqlglot-19.0.2.ebuild b/dev-python/sqlglot/sqlglot-19.0.2.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-19.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}