summaryrefslogtreecommitdiff
path: root/dev-python/sqlglot/sqlglot-18.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 22:03:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 22:03:16 +0100
commit94dd707d272879a8dfdd31d71113b1b7bba98366 (patch)
tree615875fa702a02f83e99f52ddb3a3fb0375a5674 /dev-python/sqlglot/sqlglot-18.14.0.ebuild
parent29ef84a753ab20dbbb228238713a3c7443c6520e (diff)
gentoo auto-resync : 17:10:2023 - 22:03:16
Diffstat (limited to 'dev-python/sqlglot/sqlglot-18.14.0.ebuild')
-rw-r--r--dev-python/sqlglot/sqlglot-18.14.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sqlglot/sqlglot-18.14.0.ebuild b/dev-python/sqlglot/sqlglot-18.14.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-18.14.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}