summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy/sqlalchemy-2.0.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-21 17:14:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-21 17:14:54 +0100
commitd7c0aa05b3a48c9b2bad24e3d805820f861165c6 (patch)
treebf664ec4da7846863657a931f0abfcaa0d9dfd9b /dev-python/sqlalchemy/sqlalchemy-2.0.21.ebuild
parent03633f33c2184a87f7a4cebae72542343cf0490c (diff)
gentoo auto-resync : 21:09:2023 - 17:14:53
Diffstat (limited to 'dev-python/sqlalchemy/sqlalchemy-2.0.21.ebuild')
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-2.0.21.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/sqlalchemy/sqlalchemy-2.0.21.ebuild b/dev-python/sqlalchemy/sqlalchemy-2.0.21.ebuild
index cf09ce847f97..ed6eb3f70f85 100644
--- a/dev-python/sqlalchemy/sqlalchemy-2.0.21.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-2.0.21.ebuild
@@ -8,7 +8,7 @@ DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE="sqlite?"
-inherit distutils-r1 optfeature pypi
+inherit distutils-r1 multiprocessing optfeature pypi
MY_PN="SQLAlchemy"
DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
@@ -32,6 +32,8 @@ BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
test? (
$(python_gen_impl_dep sqlite)
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
@@ -87,14 +89,8 @@ python_test() {
# means that any DeprecationWarnings from third-party plugins cause
# everything to explode
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=
- # upstream automagically depends on xdist when it is importable
- # note that we can't use xdist because it causes nodes to randomly
- # crash on init
- if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
- PYTEST_PLUGINS+=xdist.plugin
- fi
- epytest
+ epytest -p rerunfailures --reruns=10 --reruns-delay=2 \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
}
python_install_all() {