summaryrefslogtreecommitdiff
path: root/dev-python/spyder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /dev-python/spyder
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/Manifest1
-rw-r--r--dev-python/spyder/spyder-4.0.0_beta1-r1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/spyder/Manifest b/dev-python/spyder/Manifest
index 197a79d51836..e82eb7184898 100644
--- a/dev-python/spyder/Manifest
+++ b/dev-python/spyder/Manifest
@@ -12,5 +12,6 @@ EBUILD spyder-3.2.4.ebuild 1715 BLAKE2B 95fdd7a0afa73ec9967b695e92800409df2b484f
EBUILD spyder-3.2.8.ebuild 2585 BLAKE2B 9413de4f3ab9660100819266fb04b90925fbe3bdd3d322927b2379bfbde1c5bc6dbf1e69923e3775852a364020547cce51137094bce06c06d770df419ae4778d SHA512 1116f82c9ab62e714361e8ad931edbecb413f2ef6487593233309604911707bc00ad6f848d68f0f308df2d507332d448c5eeb30adfa12fb62d9166347808a6df
EBUILD spyder-3.3.0.ebuild 2470 BLAKE2B 12646b7007c16e2d925362d3b4a99c9f7a0db09cc107d7b293231f22471228a95b8cd9715fb83bf953c029c9d8b68a76d325cda12274783c163da4e623ec1a8b SHA512 d6cffb9a0c34c75b8cd8555838293719eedb2c9cbed2e23817417a3f27139c4e3fab8aff0d579d5e66f4afb9265726e8a54ffced4fd6ca1c238556377468ce04
EBUILD spyder-3.3.1.ebuild 2470 BLAKE2B 12646b7007c16e2d925362d3b4a99c9f7a0db09cc107d7b293231f22471228a95b8cd9715fb83bf953c029c9d8b68a76d325cda12274783c163da4e623ec1a8b SHA512 d6cffb9a0c34c75b8cd8555838293719eedb2c9cbed2e23817417a3f27139c4e3fab8aff0d579d5e66f4afb9265726e8a54ffced4fd6ca1c238556377468ce04
+EBUILD spyder-4.0.0_beta1-r1.ebuild 2518 BLAKE2B beaf0317f122dded42e5ec72153baea5e1f37b1cdf2eb2143181716e52de7d803781d98f156ba857b2632f3a7ba059ee29f60621ae20d084d1dcfef541b7afc1 SHA512 06edd987be3634b30161d04371c7fefd9b4da5b780fd6730bcda3083c9b60c1d83b12403c3a9264b5640a6ce30dad0ac10583d94c0e4f4d06e0065f9f4e29bd9
EBUILD spyder-4.0.0_beta1.ebuild 2525 BLAKE2B f61f578ac0238ba4a022505c0ff6ce7f19d8b5ac49327f4fff766983e418faba537855b5be236e4ba955e3dc46c8bdc8a7900d471ec54ed77a55668dc3864268 SHA512 db04046da1a43a39240d32fab56a35c06cb0d5e4b5efbbd5fde37e4b526086433c3f03f7b2c69e99b0b50ace88b0323aed582dc2bba58b3e47943f5760dac33a
MISC metadata.xml 1371 BLAKE2B 1b79aa84224554c57dc9ba4cfb888a9d18ed1b5fc99b6912de2603ac9c7866a4abb0a43a8a86df516b2b5ef3c4a0cdb18c20ea648e59002635affbdc813e2589 SHA512 8af58f099e6a7d97bd266c2d09b44ef51ec71a3ae51d61caf49968d6ecb8d830e4003171080011d390e9a27fd3010f95f22e9555a702f26e6635a4e1e02db537
diff --git a/dev-python/spyder/spyder-4.0.0_beta1-r1.ebuild b/dev-python/spyder/spyder-4.0.0_beta1-r1.ebuild
new file mode 100644
index 000000000000..e202cf128688
--- /dev/null
+++ b/dev-python/spyder/spyder-4.0.0_beta1-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6} )
+
+inherit eutils distutils-r1 xdg-utils
+MY_P=${P/_beta/b}
+
+DESCRIPTION="The Scientific PYthon Development EnviRonment"
+HOMEPAGE="
+ https://www.spyder-ide.org/
+ https://github.com/spyder-ide/spyder/
+ https://pypi.org/project/spyder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hdf5 +webengine webkit"
+REQUIRED_USE="webengine? ( !webkit )"
+
+RDEPEND="
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.11.0[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pickleshare[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},svg,webengine?,webkit?]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ >=dev-python/qtawesome-0.4.1[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},svg,webengine?,webkit?]
+ >=dev-python/rope-0.10.7[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ >=dev-python/spyder-kernels-1.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Based on the courtesy of Arfrever
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript scripts/${PN} ${PN}${EPYTHON:6:1}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon spyder/images/spyder.svg
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "To get additional features, optional runtime dependencies may be installed:"
+ optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
+ optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
+ optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
+ optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
+ optfeature "Import Matlab workspace files in the Variable Explorer" sci-libs/scipy
+ optfeature "Run Cython files in the IPython console" dev-python/cython
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}