summaryrefslogtreecommitdiff
path: root/dev-python/spyder/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-python/spyder/files
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-python/spyder/files')
-rw-r--r--dev-python/spyder/files/spyder-3.2.4-build.patch130
-rw-r--r--dev-python/spyder/files/spyder-3.2.8-build.patch129
-rw-r--r--dev-python/spyder/files/spyder-3.3.0-build.patch49
-rw-r--r--dev-python/spyder/files/spyder-3.3.1-build.patch49
-rw-r--r--dev-python/spyder/files/spyder-4.0.1-build.patch (renamed from dev-python/spyder/files/spyder-4.0.0_beta1-build.patch)14
-rw-r--r--dev-python/spyder/files/spyder-4.0.1-py3-only.patch56
6 files changed, 56 insertions, 371 deletions
diff --git a/dev-python/spyder/files/spyder-3.2.4-build.patch b/dev-python/spyder/files/spyder-3.2.4-build.patch
deleted file mode 100644
index 2a1fee52131b..000000000000
--- a/dev-python/spyder/files/spyder-3.2.4-build.patch
+++ /dev/null
@@ -1,130 +0,0 @@
---- spyder-3.2.3.orig/setup.py 2017-08-29 00:42:56.000000000 +0200
-+++ spyder-3.2.3/setup.py 2017-09-16 20:57:08.610147911 +0200
-@@ -77,13 +77,7 @@
- def get_data_files():
- """Return data_files in a platform dependent manner"""
- if sys.platform.startswith('linux'):
-- if PY3:
-- data_files = [('share/applications', ['scripts/spyder3.desktop']),
-- ('share/pixmaps', ['img_src/spyder3.png']),
-- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
-- else:
-- data_files = [('share/applications', ['scripts/spyder.desktop']),
-- ('share/pixmaps', ['img_src/spyder.png'])]
-+ data_files = [('share/pixmaps', ['img_src/spyder.png'])]
- elif os.name == 'nt':
- data_files = [('scripts', ['img_src/spyder.ico',
- 'img_src/spyder_reset.ico'])]
-@@ -106,102 +100,6 @@
-
-
- #==============================================================================
--# Make Linux detect Spyder desktop file
--#==============================================================================
--class MyInstallData(install_data):
-- def run(self):
-- install_data.run(self)
-- if sys.platform.startswith('linux'):
-- try:
-- subprocess.call(['update-desktop-database'])
-- except:
-- print("ERROR: unable to update desktop database",
-- file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--#==============================================================================
--# Sphinx build (documentation)
--#==============================================================================
--def get_html_help_exe():
-- """Return HTML Help Workshop executable path (Windows only)"""
-- if os.name == 'nt':
-- hhc_base = r'C:\Program Files%s\HTML Help Workshop\hhc.exe'
-- for hhc_exe in (hhc_base % '', hhc_base % ' (x86)'):
-- if osp.isfile(hhc_exe):
-- return hhc_exe
-- else:
-- return
--
--try:
-- from sphinx import setup_command
--
-- class MyBuild(build):
-- user_options = [('no-doc', None, "Don't build Spyder documentation")] \
-- + build.user_options
-- def __init__(self, *args, **kwargs):
-- build.__init__(self, *args, **kwargs)
-- self.no_doc = False
-- def with_doc(self):
-- setup_dir = os.path.dirname(os.path.abspath(__file__))
-- is_doc_dir = os.path.isdir(os.path.join(setup_dir, 'doc'))
-- install_obj = self.distribution.get_command_obj('install')
-- return (is_doc_dir and not self.no_doc and not install_obj.no_doc)
-- sub_commands = build.sub_commands + [('build_doc', with_doc)]
-- CMDCLASS['build'] = MyBuild
--
--
-- class MyInstall(install):
-- user_options = [('no-doc', None, "Don't build Spyder documentation")] \
-- + install.user_options
-- def __init__(self, *args, **kwargs):
-- install.__init__(self, *args, **kwargs)
-- self.no_doc = False
-- CMDCLASS['install'] = MyInstall
--
--
-- class MyBuildDoc(setup_command.BuildDoc):
-- def run(self):
-- build = self.get_finalized_command('build')
-- sys.path.insert(0, os.path.abspath(build.build_lib))
-- dirname = self.distribution.get_command_obj('build').build_purelib
-- self.builder_target_dir = osp.join(dirname, 'spyder', 'doc')
--
-- if not osp.exists(self.builder_target_dir):
-- os.mkdir(self.builder_target_dir)
--
-- hhc_exe = get_html_help_exe()
-- self.builder = "html" if hhc_exe is None else "htmlhelp"
--
-- try:
-- setup_command.BuildDoc.run(self)
-- except UnicodeDecodeError:
-- print("ERROR: unable to build documentation because Sphinx "\
-- "do not handle source path with non-ASCII characters. "\
-- "Please try to move the source package to another "\
-- "location (path with *only* ASCII characters).",
-- file=sys.stderr)
-- sys.path.pop(0)
--
-- # Building chm doc, if HTML Help Workshop is installed
-- if hhc_exe is not None:
-- fname = osp.join(self.builder_target_dir, 'Spyderdoc.chm')
-- subprocess.call('"%s" %s' % (hhc_exe, fname), shell=True)
-- if osp.isfile(fname):
-- dest = osp.join(dirname, 'spyder')
-- try:
-- shutil.move(fname, dest)
-- except shutil.Error:
-- print("Unable to replace %s" % dest)
-- shutil.rmtree(self.builder_target_dir)
--
-- CMDCLASS['build_doc'] = MyBuildDoc
--except ImportError:
-- print('WARNING: unable to build documentation because Sphinx '\
-- 'is not installed', file=sys.stderr)
--
--
--#==============================================================================
- # Main scripts
- #==============================================================================
- # NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
-@@ -261,8 +159,7 @@
- 'Programming Language :: Python :: 3',
- 'Development Status :: 5 - Production/Stable',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=CMDCLASS)
-+ 'Topic :: Software Development :: Widget Sets'])
-
-
- #==============================================================================
diff --git a/dev-python/spyder/files/spyder-3.2.8-build.patch b/dev-python/spyder/files/spyder-3.2.8-build.patch
deleted file mode 100644
index b21c77d660be..000000000000
--- a/dev-python/spyder/files/spyder-3.2.8-build.patch
+++ /dev/null
@@ -1,129 +0,0 @@
---- spyder-3.2.8/setup.py 2018-03-23 14:00:00.000000000 +0100
-+++ spyder-3.2.8/setup.py 2018-03-23 14:00:00.000000001 +0100
-@@ -77,12 +77,7 @@
- def get_data_files():
- """Return data_files in a platform dependent manner"""
- if sys.platform.startswith('linux'):
-- if PY3:
-- data_files = [('share/applications', ['scripts/spyder3.desktop']),
-- ('share/icons', ['img_src/spyder3.png']),
-- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
-- else:
-- data_files = [('share/applications', ['scripts/spyder.desktop']),
-+ data_files = [('share/applications', ['scripts/spyder.desktop']),
- ('share/icons', ['img_src/spyder.png'])]
- elif os.name == 'nt':
- data_files = [('scripts', ['img_src/spyder.ico',
-@@ -106,102 +101,6 @@
-
-
- #==============================================================================
--# Make Linux detect Spyder desktop file
--#==============================================================================
--class MyInstallData(install_data):
-- def run(self):
-- install_data.run(self)
-- if sys.platform.startswith('linux'):
-- try:
-- subprocess.call(['update-desktop-database'])
-- except:
-- print("ERROR: unable to update desktop database",
-- file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--#==============================================================================
--# Sphinx build (documentation)
--#==============================================================================
--def get_html_help_exe():
-- """Return HTML Help Workshop executable path (Windows only)"""
-- if os.name == 'nt':
-- hhc_base = r'C:\Program Files%s\HTML Help Workshop\hhc.exe'
-- for hhc_exe in (hhc_base % '', hhc_base % ' (x86)'):
-- if osp.isfile(hhc_exe):
-- return hhc_exe
-- else:
-- return
--
--try:
-- from sphinx import setup_command
--
-- class MyBuild(build):
-- user_options = [('no-doc', None, "Don't build Spyder documentation")] \
-- + build.user_options
-- def __init__(self, *args, **kwargs):
-- build.__init__(self, *args, **kwargs)
-- self.no_doc = False
-- def with_doc(self):
-- setup_dir = os.path.dirname(os.path.abspath(__file__))
-- is_doc_dir = os.path.isdir(os.path.join(setup_dir, 'doc'))
-- install_obj = self.distribution.get_command_obj('install')
-- return (is_doc_dir and not self.no_doc and not install_obj.no_doc)
-- sub_commands = build.sub_commands + [('build_doc', with_doc)]
-- CMDCLASS['build'] = MyBuild
--
--
-- class MyInstall(install):
-- user_options = [('no-doc', None, "Don't build Spyder documentation")] \
-- + install.user_options
-- def __init__(self, *args, **kwargs):
-- install.__init__(self, *args, **kwargs)
-- self.no_doc = False
-- CMDCLASS['install'] = MyInstall
--
--
-- class MyBuildDoc(setup_command.BuildDoc):
-- def run(self):
-- build = self.get_finalized_command('build')
-- sys.path.insert(0, os.path.abspath(build.build_lib))
-- dirname = self.distribution.get_command_obj('build').build_purelib
-- self.builder_target_dir = osp.join(dirname, 'spyder', 'doc')
--
-- if not osp.exists(self.builder_target_dir):
-- os.mkdir(self.builder_target_dir)
--
-- hhc_exe = get_html_help_exe()
-- self.builder = "html" if hhc_exe is None else "htmlhelp"
--
-- try:
-- setup_command.BuildDoc.run(self)
-- except UnicodeDecodeError:
-- print("ERROR: unable to build documentation because Sphinx "\
-- "do not handle source path with non-ASCII characters. "\
-- "Please try to move the source package to another "\
-- "location (path with *only* ASCII characters).",
-- file=sys.stderr)
-- sys.path.pop(0)
--
-- # Building chm doc, if HTML Help Workshop is installed
-- if hhc_exe is not None:
-- fname = osp.join(self.builder_target_dir, 'Spyderdoc.chm')
-- subprocess.call('"%s" %s' % (hhc_exe, fname), shell=True)
-- if osp.isfile(fname):
-- dest = osp.join(dirname, 'spyder')
-- try:
-- shutil.move(fname, dest)
-- except shutil.Error:
-- print("Unable to replace %s" % dest)
-- shutil.rmtree(self.builder_target_dir)
--
-- CMDCLASS['build_doc'] = MyBuildDoc
--except ImportError:
-- print('WARNING: unable to build documentation because Sphinx '\
-- 'is not installed', file=sys.stderr)
--
--
--#==============================================================================
- # Main scripts
- #==============================================================================
- # NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
-@@ -261,8 +160,7 @@
- 'Programming Language :: Python :: 3',
- 'Development Status :: 5 - Production/Stable',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=CMDCLASS)
-+ 'Topic :: Software Development :: Widget Sets'])
-
-
- #==============================================================================
diff --git a/dev-python/spyder/files/spyder-3.3.0-build.patch b/dev-python/spyder/files/spyder-3.3.0-build.patch
deleted file mode 100644
index f6037237e0c0..000000000000
--- a/dev-python/spyder/files/spyder-3.3.0-build.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -r -U3 spyder-3.3.0.orig/setup.py spyder-3.3.0/setup.py
---- spyder-3.3.0.orig/setup.py 2018-06-27 11:28:24.000000000 +0700
-+++ spyder-3.3.0/setup.py 2018-08-07 23:26:17.609046673 +0700
-@@ -75,12 +75,7 @@
- def get_data_files():
- """Return data_files in a platform dependent manner"""
- if sys.platform.startswith('linux'):
-- if PY3:
-- data_files = [('share/applications', ['scripts/spyder3.desktop']),
-- ('share/icons', ['img_src/spyder3.png']),
-- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
-- else:
-- data_files = [('share/applications', ['scripts/spyder.desktop']),
-+ data_files = [('share/applications', ['scripts/spyder.desktop']),
- ('share/icons', ['img_src/spyder.png'])]
- elif os.name == 'nt':
- data_files = [('scripts', ['img_src/spyder.ico',
-@@ -104,21 +99,6 @@
-
-
- #==============================================================================
--# Make Linux detect Spyder desktop file
--#==============================================================================
--class MyInstallData(install_data):
-- def run(self):
-- install_data.run(self)
-- if sys.platform.startswith('linux'):
-- try:
-- subprocess.call(['update-desktop-database'])
-- except:
-- print("ERROR: unable to update desktop database",
-- file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--#==============================================================================
- # Main scripts
- #==============================================================================
- # NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
-@@ -178,8 +158,7 @@
- 'Programming Language :: Python :: 3',
- 'Development Status :: 5 - Production/Stable',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=CMDCLASS)
-+ 'Topic :: Software Development :: Widget Sets'])
-
-
- #==============================================================================
diff --git a/dev-python/spyder/files/spyder-3.3.1-build.patch b/dev-python/spyder/files/spyder-3.3.1-build.patch
deleted file mode 100644
index 1561dbdcc1e1..000000000000
--- a/dev-python/spyder/files/spyder-3.3.1-build.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -r -U3 spyder-3.3.1.orig/setup.py spyder-3.3.1/setup.py
---- spyder-3.3.1.orig/setup.py 2018-08-10 10:46:02.000000000 +0700
-+++ spyder-3.3.1/setup.py 2018-08-14 19:16:10.921323804 +0700
-@@ -83,12 +83,7 @@
- def get_data_files():
- """Return data_files in a platform dependent manner"""
- if sys.platform.startswith('linux'):
-- if PY3:
-- data_files = [('share/applications', ['scripts/spyder3.desktop']),
-- ('share/icons', ['img_src/spyder3.png']),
-- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
-- else:
-- data_files = [('share/applications', ['scripts/spyder.desktop']),
-+ data_files = [('share/applications', ['scripts/spyder.desktop']),
- ('share/icons', ['img_src/spyder.png'])]
- elif os.name == 'nt':
- data_files = [('scripts', ['img_src/spyder.ico',
-@@ -112,21 +107,6 @@
-
-
- #==============================================================================
--# Make Linux detect Spyder desktop file
--#==============================================================================
--class MyInstallData(install_data):
-- def run(self):
-- install_data.run(self)
-- if sys.platform.startswith('linux'):
-- try:
-- subprocess.call(['update-desktop-database'])
-- except:
-- print("ERROR: unable to update desktop database",
-- file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--#==============================================================================
- # Main scripts
- #==============================================================================
- # NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
-@@ -210,8 +190,7 @@
- 'Intended Audience :: Science/Research',
- 'Intended Audience :: Developers',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=CMDCLASS)
-+ 'Topic :: Software Development :: Widget Sets'])
-
-
- #==============================================================================
diff --git a/dev-python/spyder/files/spyder-4.0.0_beta1-build.patch b/dev-python/spyder/files/spyder-4.0.1-build.patch
index 2b0f9bc699f3..7463550fc165 100644
--- a/dev-python/spyder/files/spyder-4.0.0_beta1-build.patch
+++ b/dev-python/spyder/files/spyder-4.0.1-build.patch
@@ -1,20 +1,6 @@
diff -r -U3 spyder-4.0.0b1.orig/setup.py spyder-4.0.0b1/setup.py
--- spyder-4.0.0b1.orig/setup.py 2018-08-12 04:35:49.000000000 +0700
+++ spyder-4.0.0b1/setup.py 2018-08-14 20:25:32.827148778 +0700
-@@ -83,12 +83,7 @@
- def get_data_files():
- """Return data_files in a platform dependent manner"""
- if sys.platform.startswith('linux'):
-- if PY3:
-- data_files = [('share/applications', ['scripts/spyder3.desktop']),
-- ('share/icons', ['img_src/spyder3.png']),
-- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
-- else:
-- data_files = [('share/applications', ['scripts/spyder.desktop']),
-+ data_files = [('share/applications', ['scripts/spyder.desktop']),
- ('share/icons', ['img_src/spyder.png'])]
- elif os.name == 'nt':
- data_files = [('scripts', ['img_src/spyder.ico',
@@ -112,21 +107,6 @@
diff --git a/dev-python/spyder/files/spyder-4.0.1-py3-only.patch b/dev-python/spyder/files/spyder-4.0.1-py3-only.patch
new file mode 100644
index 000000000000..df5f0c4ad1c6
--- /dev/null
+++ b/dev-python/spyder/files/spyder-4.0.1-py3-only.patch
@@ -0,0 +1,56 @@
+diff --git a/setup.py b/setup.py
+index a492549..b77f758 100644
+--- a/setup.py
++++ b/setup.py
+@@ -31,13 +31,6 @@ import shutil
+ from distutils.core import setup
+ from distutils.command.install_data import install_data
+
+-
+-#==============================================================================
+-# Check for Python 3
+-#==============================================================================
+-PY3 = sys.version_info[0] == 3
+-
+-
+ #==============================================================================
+ # Minimal Python version sanity check
+ # Taken from the notebook setup.py -- Modified BSD License
+@@ -87,13 +80,8 @@ def get_subpackages(name):
+ def get_data_files():
+ """Return data_files in a platform dependent manner"""
+ if sys.platform.startswith('linux'):
+- if PY3:
+- data_files = [('share/applications', ['scripts/spyder3.desktop']),
+- ('share/icons', ['img_src/spyder3.png']),
+- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
+- else:
+- data_files = [('share/applications', ['scripts/spyder.desktop']),
+- ('share/icons', ['img_src/spyder.png'])]
++ data_files = [('share/applications', ['scripts/spyder.desktop']),
++ ('share/pixmaps', ['img_src/spyder.png'])]
+ elif os.name == 'nt':
+ data_files = [('scripts', ['img_src/spyder.ico',
+ 'img_src/spyder_reset.ico'])]
+@@ -115,10 +103,7 @@ def get_packages():
+ # platforms due to a bug in pip installation process
+ # See spyder-ide/spyder#1158.
+ SCRIPTS = ['%s_win_post_install.py' % NAME]
+-if PY3 and sys.platform.startswith('linux'):
+- SCRIPTS.append('spyder3')
+-else:
+- SCRIPTS.append('spyder')
++SCRIPTS.append('spyder')
+
+
+ #==============================================================================
+@@ -246,8 +231,7 @@ if 'setuptools' in sys.modules:
+
+ setup_args['entry_points'] = {
+ 'gui_scripts': [
+- '{} = spyder.app.start:main'.format(
+- 'spyder3' if PY3 else 'spyder')
++ '{} = spyder.app.start:main'.format('spyder')
+ ]
+ }
+