summaryrefslogtreecommitdiff
path: root/dev-python/spyder-unittest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/spyder-unittest
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/spyder-unittest')
-rw-r--r--dev-python/spyder-unittest/Manifest2
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/spyder-unittest/Manifest b/dev-python/spyder-unittest/Manifest
index e553e379be93..35b19152eacf 100644
--- a/dev-python/spyder-unittest/Manifest
+++ b/dev-python/spyder-unittest/Manifest
@@ -1,3 +1,5 @@
DIST spyder-unittest-0.4.1.tar.gz 79158 BLAKE2B 10b7a8fde9dffdb436c44f22d305ceab84970dabd19aaeb7b5685be21f0e7bfc701a5fbbf9e393a71c9feb36dd6a2be68680e276c8d0841b2133a7171c504e3f SHA512 17e08b09accd938bf533c409f9a8011e9780f9cc4533af0ec754b6a01061490f198213cb77af9050e1e67e2b4b9c25251bbab27dce23d3f6e09f502cfbef95fc
+DIST spyder-unittest-0.4.1_p20220106.tar.gz 80022 BLAKE2B c904196f7b0288b4d4f105037cbf75fc7ef60669ba1a24687b4f6aa672b88b139b64282c2d12340c958a3ffb65b8cf01b61256f669e167a6c15eb9471430af2a SHA512 4bea5d88b6be80435e2fa6498803ceea275b72c47bd0a54bb3be962bfe00feed2073e4d4915ea1b4dd780cb1c104f6dcd2735ee000cdedb934ed9fac059d0ca5
EBUILD spyder-unittest-0.4.1-r1.ebuild 1173 BLAKE2B d64d8c767b2885c207195d69f00788a2fb236bae5ae4a460c3fbffd140a8e3efbdc1b7fe02f8496b646664de2fd9013fde853385155b81dc922b45f3032be06e SHA512 01c3be4900ebf154a9c5287bb0cebaeb0c7940ff8046c64a089b869b322d24298e8906abd3769424061274cffd62cd286938bb286c1125dc6e292b461e31a87b
+EBUILD spyder-unittest-0.4.1_p20220106.ebuild 962 BLAKE2B d208963967af955ad561728a41571174ec6ab345ef66668125a65ecb9597f6fe187dc822a3fa49956c16ad7c75bfddf6364cd925c54bbb389bcbf962b74b178b SHA512 cef521c41084a7522fcf57c466cc7a4ca581a45914bd389f3332e2e16968791043385227b697debe601686e3bf6a278303546dfecde3e1f01ec55c615222dd28
MISC metadata.xml 361 BLAKE2B 9d9ab5a6fcc2bd47042aaca2342fe7603ccf68929f35e45d2f4435b62bdbee2fcfc8ebf236b3e6930154387a2c83b775cb9782d50db13343ac96f7a325bb9a82 SHA512 4227a170633b961a20a045cdbd39dd2438d02fdfe94b41e9801198f126fe4578285bc16097a8377357ea70ff625b7e47e5a2573af88ca6dd27ab1fac0235d05c
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild
new file mode 100644
index 000000000000..e60fa49b0a8b
--- /dev/null
+++ b/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+COMMIT="d210d9fe6c4efbb21d680a040cc4741d76a81f49"
+
+DESCRIPTION="Plugin for Spyder to run tests and view the results"
+HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# AttributeError: 'NoneType' object has no attribute 'split'
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}