summaryrefslogtreecommitdiff
path: root/dev-python/spyder-notebook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 17:32:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 17:32:06 +0100
commit7138219e3c9446bf981ff17f5609f42130bec414 (patch)
treeb898b17778ed104dd89b2980386bae53594b001d /dev-python/spyder-notebook
parent1afe1c223c048ca2c33fa230c83d620c04fecb8f (diff)
gentoo auto-resync : 24:09:2022 - 17:32:06
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest3
-rw-r--r--dev-python/spyder-notebook/metadata.xml12
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.4.0.ebuild45
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
new file mode 100644
index 000000000000..13e217448cd1
--- /dev/null
+++ b/dev-python/spyder-notebook/Manifest
@@ -0,0 +1,3 @@
+DIST spyder-notebook-0.4.0.gh.tar.gz 3869758 BLAKE2B db809e9a2b93206ba0236e825b7d8f612efe552be5b9bbcdd60021ee143f16674e05847834bbd63a801c32e2264e5335685887aad0519033a315b3c2c0fcd3d6 SHA512 ab97429d276af815411b9a63bc04e291e5ed596bb9c551be8161e71761fc21a61b896b73ec1d93c9a2b4561ba228b93ac86f3b542a515cbfc651e9e218f6f778
+EBUILD spyder-notebook-0.4.0.ebuild 1244 BLAKE2B 86c66de910ff86ac170f8d6b894878ade3c0cf5f2482213f773d28c978b1ba6a6e4e386f4be859c1bda821851943ed4bcf4cd4cd4180cfe20eb91401cc1b87ae SHA512 79eeb301f1bfc4025091c13cecc77d890374d4babbd7d15ad30699dd7a88cb1944387accc099085c458c6e6970f2df6b2208470bf68454cee367ec4c74b89ea7
+MISC metadata.xml 361 BLAKE2B 0dd7289b209a7df06e5cb73dc020a786daa17df5776a5c75d89e33ae88625735fea7680014b1210c3b1ef28bd109bec4d29888c3a381771eb6f1eb34c6383642 SHA512 d3f9634673f762f77b79bdd9612d75cb8e56b8adf5996240469c61c86d6ea5a4c1ecb5443a956a549dbeaa95314487f5a51c0075fe5a9f1bcdf96685388a0d93
diff --git a/dev-python/spyder-notebook/metadata.xml b/dev-python/spyder-notebook/metadata.xml
new file mode 100644
index 000000000000..32373b5ff3a3
--- /dev/null
+++ b/dev-python/spyder-notebook/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">spyder-notebook</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.4.0.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.4.0.ebuild
new file mode 100644
index 000000000000..4d32ebced7fc
--- /dev/null
+++ b/dev-python/spyder-notebook/spyder-notebook-0.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+# ERROR: Server components are missing!! Please run 'python setup.py sdist' first.
+# DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/notebook-4.3[${PYTHON_USEDEP}]
+ dev-python/qdarkstyle[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.3.3[${PYTHON_USEDEP}]
+ <dev-python/spyder-6[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}