summaryrefslogtreecommitdiff
path: root/dev-python/spyder-line-profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
commite59b99df9503539c0231e655a17bccf83f8a270d (patch)
treedbd3fc51c710879436a4122898a3653c8c0d4ae8 /dev-python/spyder-line-profiler
parent9fce2d9787c37a690336f5e345a49d83ee60bc8a (diff)
gentoo auto-resync : 25:06:2023 - 07:29:14
Diffstat (limited to 'dev-python/spyder-line-profiler')
-rw-r--r--dev-python/spyder-line-profiler/Manifest2
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/Manifest b/dev-python/spyder-line-profiler/Manifest
index e3bca923256c..d32dbe7932d7 100644
--- a/dev-python/spyder-line-profiler/Manifest
+++ b/dev-python/spyder-line-profiler/Manifest
@@ -1,3 +1,5 @@
DIST spyder-line-profiler-0.3.1.gh.tar.gz 44042 BLAKE2B a98c5770b44b3e11d2261b371e5a806087ebcb347b54745b5bdfe5c4fe3051ff862c79e96ab9a0048e83217cba65fd48a6368bf3e1d1a3f9ab09d2dd69f8ec7c SHA512 96ddc1817adfd58362ea766b95cd58ad521c1333a6bafe9fef1e117ef7ef602bc7e7bced3990d19b85c2882253d81d27940ab409a9daacf588513a405ae4d8fb
+DIST spyder-line-profiler-0.3.2.gh.tar.gz 88725 BLAKE2B 9e15a9b88d1b36a39428e7eccafb7a2c3d3609aece2c6e5c2f379c9f9180093863472bd1e071b12bf313e7cb6ccd4993bb407785716cab2dda871a1ebd527d41 SHA512 fb2e86cc640c7cd32567852063845567634e7cec365f7f5f5f3d770316b9adabc0447d3ad8334411fe3894aeb086cde4f14b77fd3483c099296db7df15f0b46b
EBUILD spyder-line-profiler-0.3.1-r1.ebuild 817 BLAKE2B f48282222d680923dc748ec30f05b9cf24d7e5c0bd3455363272cf1f8fce7cb3bfb47c23cfb7eb83a88407855d14a3ce2b6eb5375f75ca87a149be8b90a222c0 SHA512 c62e96b0e80e4858e58c46ffa23f3af50628011d20b7c4d2d3710acf727406027d27b2a560ede9d41e2fec99d1aa26f98e9562decd75edabb7fac1e2e4cc2f3a
+EBUILD spyder-line-profiler-0.3.2.ebuild 879 BLAKE2B 02504b3da0d66916393228fb9d1e107ca576357f820c00d4c8a7df765baebca5c52fb0d4024330a6839c5ab7823b1ff8270fdccaa496eb4aef35cdecb5375cd1 SHA512 2da02a8de9aea344a12c87716a021e1c6bb67c0a5f5c841ac3ca7bb72ff823f2daf6dcf714f87cb88a0ad49f4c3b53eadfc691b217b4ec18203f9d392d255320
MISC metadata.xml 437 BLAKE2B 254a233cdcef8d6960ba16b23c7d7db791b3291895ea2d6327691565bd9fc25c059727598cfe4893749ce691556c3d7c0edb006c6d7f2f39ca596a838bba16d3 SHA512 df4a0bce4f15301ff686c91e9d921dced3821659cd9a4fcbcc1866114fdbcecccb01452ce53ae75b270a38d38dbf838f2a603fdab6aeae1e709a530584a9c9e8
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild
new file mode 100644
index 000000000000..b67f71095543
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="
+ https://github.com/spyder-ide/spyder-line-profiler/
+ https://pypi.org/project/spyder-line-profiler/
+"
+SRC_URI="
+ https://github.com/spyder-ide/spyder-line-profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-6.0.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}