summaryrefslogtreecommitdiff
path: root/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-05 16:24:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-05 16:24:39 +0100
commit4aec9255c99411cb07138353f1bdda61fe0b501d (patch)
tree034e5a94d1660a6fa13cec598dfb476647978e20 /dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild
parenta0f09b2c947909b614c52fcfbdce964469404101 (diff)
gentoo auto-resync : 05:09:2022 - 16:24:39
Diffstat (limited to 'dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild')
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild
new file mode 100644
index 000000000000..dc37126b66a1
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="https://github.com/spyder-ide/spyder-line-profiler"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-6.0.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}