summaryrefslogtreecommitdiff
path: root/dev-python/spotipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-14 17:46:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-14 17:46:07 +0100
commit234dc35b5df19cfe20396a10855ce4e70b8b43bc (patch)
treeac566e09df315eef8fd8be0d3233e33355fe92fa /dev-python/spotipy
parentee6e636931804ef8c1d7f395e3a3400b9f8f5614 (diff)
gentoo auto-resync : 14:04:2023 - 17:46:06
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest2
-rw-r--r--dev-python/spotipy/spotipy-2.22.1.ebuild51
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index e43f286bfff2..beaf7584285a 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1,5 +1,3 @@
-DIST spotipy-2.22.1.gh.tar.gz 111228 BLAKE2B df75cce406d59c9de3e4c836309262d61f7f1249761d3172be13033512944e69a56ca67f16b55e4736f760b74d3ebd8f384225ce9309a5fc1bd8c93be4099069 SHA512 d8c5871dd606e3335656fb55fa042d8c91c72a4c7d62a584bd407a7546184996694c67d499f908fc7049e406c548269286de6cba17064f0385adba3661b34c3b
DIST spotipy-2.23.0.gh.tar.gz 112399 BLAKE2B 5510ce35624c561df61fffee78f211dfa91ff8d5b3dc15d37c96a51bf830e67aac9c6a0787c71715bee17a3ba91b84766c1ecec37d5775f2182617f2b74a2cb3 SHA512 52955fa3365d5153f19f60874ce8e96910ac8db783499e0e2ef2ab31127277844e24a045115dc522dd7b7535f7907de56da87e02a63b94ee7506b75c1e108e9b
-EBUILD spotipy-2.22.1.ebuild 1061 BLAKE2B a9b86d8573e68470720300de8a97b40b96b277d874e3f527da9f4f7dfd5abc660b65ba6276e6ea68cd87280abce55f2a6f8db913174a894f25eab3bcef0fba66 SHA512 94c4517c0e2fe6dd842df5e6fcc89bf3b5fa0a3fee5931d19bedc39f0db7c4a6ed8b64f04293c63070c4f965d3be1d6fae75719ba7587b83e03128ac74ddb0db
EBUILD spotipy-2.23.0.ebuild 1061 BLAKE2B a9b86d8573e68470720300de8a97b40b96b277d874e3f527da9f4f7dfd5abc660b65ba6276e6ea68cd87280abce55f2a6f8db913174a894f25eab3bcef0fba66 SHA512 94c4517c0e2fe6dd842df5e6fcc89bf3b5fa0a3fee5931d19bedc39f0db7c4a6ed8b64f04293c63070c4f965d3be1d6fae75719ba7587b83e03128ac74ddb0db
MISC metadata.xml 563 BLAKE2B 59aaf72f0ef6dcd61187b4d6c4f058725954a01e692fcc3caec5d559a340cf8587950fe96af3c8e10eab4c27ed7a8074cc98ad955b576a261eb8eb9dbe4d6403 SHA512 99afcacd9adfe51850503848dcaebc3d7be85cf50a05dba05ea64c7a9af7d641dbe3db903e611030698f4c7025d99b2057a03e34eca85bc4ac4d811fe961f799
diff --git a/dev-python/spotipy/spotipy-2.22.1.ebuild b/dev-python/spotipy/spotipy-2.22.1.ebuild
deleted file mode 100644
index 6a9d5ec4fcdc..000000000000
--- a/dev-python/spotipy/spotipy-2.22.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight Python library for the Spotify Web API"
-HOMEPAGE="
- https://spotipy.readthedocs.io/
- https://github.com/spotipy-dev/spotipy/
- https://pypi.org/project/spotipy/
-"
-SRC_URI="
- https://github.com/spotipy-dev/spotipy/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-KEYWORDS="amd64 ~x86"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- dev-python/redis[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Internet
- tests/unit/test_oauth.py::TestSpotifyClientCredentials::test_spotify_client_credentials_get_access_token
-)
-
-python_install_all() {
- distutils-r1_python_install_all
-
- use examples && dodoc -r examples
-}