summaryrefslogtreecommitdiff
path: root/dev-python/sphobjinv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/sphobjinv
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/sphobjinv')
-rw-r--r--dev-python/sphobjinv/Manifest2
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.2.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphobjinv/Manifest b/dev-python/sphobjinv/Manifest
index d16d758370ff..4b84978b704a 100644
--- a/dev-python/sphobjinv/Manifest
+++ b/dev-python/sphobjinv/Manifest
@@ -1,3 +1,5 @@
DIST sphobjinv-2.1.tar.gz 1144017 BLAKE2B 71878e1bac5202ab74298b56cd6172236ea524050323e0d6b8bbc0c89f1937d75f10d40b4071cfbe8c9031641e9a0ecb283da908c40840a61c12a7c892438241 SHA512 cde77d73b09b72358b0ac5b0d8f1a748e78dce6664d1b849ba68f5ff70dc43cbcff4581374d0151be29c4d97efe2920c5c00ff68918371243be158031e9554fa
+DIST sphobjinv-2.2.tar.gz 1150648 BLAKE2B db29624c9e7c5ec014793bb76693dfbe87d8742a688b91c196bec12ac03852ae7999717588e075f58f5d2c3109b10d532bd117d482b540d30af27760869a5904 SHA512 257327ad168d5804639d3a064db683e0b9eb4f1dcb864a12a8ba440f3fde31c832bd72298f6381d2590bfac85ffe811563b8de124a135de2b6c1511217925103
EBUILD sphobjinv-2.1-r1.ebuild 1387 BLAKE2B 107abe0e53cebde1dc43e5eb2fcb9e11f5cc3cd56bd873947f460c561dd85c2cb2c65d4e90241d4e58306868e7f83e1acce74b386ac6f842abd669bfe83828b4 SHA512 23a796385f377571388107d6b3bdea1dc763005325bb824aa3d6a3975b0bb52bd13d353cd5577b587c92e20d8e08b5be288c8012400e262a69fd632a54079995
+EBUILD sphobjinv-2.2.ebuild 1356 BLAKE2B 2c1bafaf34db8941c0be0c5b5946d0f4af94f3b262f40447b753aea2f3f15744518b9ef00ddac1315a7fe66db6cb287f5e627c56d32473a105e74ece027d3755 SHA512 57ab85fb1967d6afa5cdb157c1f20c5d1bf78808bc5cbd2a11cf441e2e93ead802ca19c242836f717983d694e89d07c479267bf9c252ed45787957b8d4f8a345
MISC metadata.xml 894 BLAKE2B 9e3b9ad864c23cd1cf346de1c06bf25035de4566733c1716846267aeba3aa09c025e04b15b67369e74f703e4b3205d89e35fd6614627d9f5630fd233320843eb SHA512 f5407da0c6c12279317b17d7174627d1fc3a42f249c1e63acd73c0367c526aab6b62fd358a34760c4986d3d487839905e2ddf5e40c62668933280c5278fefd9e
diff --git a/dev-python/sphobjinv/sphobjinv-2.2.ebuild b/dev-python/sphobjinv/sphobjinv-2.2.ebuild
new file mode 100644
index 000000000000..d3097e5c313a
--- /dev/null
+++ b/dev-python/sphobjinv/sphobjinv-2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx objects.inv Inspection/Manipulation Tool"
+HOMEPAGE="
+ https://github.com/bskinn/sphobjinv/
+ https://pypi.org/project/sphobjinv/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/dictdiffer[${PYTHON_USEDEP}]
+ dev-python/pytest-check[${PYTHON_USEDEP}]
+ dev-python/pytest-ordering[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/stdio-mgr-1.0.1[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues \
+ dev-python/sphinxcontrib-programoutput
+
+src_prepare() {
+ # --strict option is deprecated in pytest>6
+ sed -i -e '/addopts/d' tox.ini || die
+ sed -e '/CLI_TEST_TIMEOUT/s/2/20/' -i tests/test_cli.py || die
+
+ distutils-r1_src_prepare
+}