summaryrefslogtreecommitdiff
path: root/dev-python/sphobjinv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/sphobjinv
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/sphobjinv')
-rw-r--r--dev-python/sphobjinv/Manifest3
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.1-r1.ebuild49
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.1.ebuild2
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/sphobjinv/Manifest b/dev-python/sphobjinv/Manifest
index 5525d1e04cf6..3aff17afa980 100644
--- a/dev-python/sphobjinv/Manifest
+++ b/dev-python/sphobjinv/Manifest
@@ -1,3 +1,4 @@
DIST sphobjinv-2.1.tar.gz 1144017 BLAKE2B 71878e1bac5202ab74298b56cd6172236ea524050323e0d6b8bbc0c89f1937d75f10d40b4071cfbe8c9031641e9a0ecb283da908c40840a61c12a7c892438241 SHA512 cde77d73b09b72358b0ac5b0d8f1a748e78dce6664d1b849ba68f5ff70dc43cbcff4581374d0151be29c4d97efe2920c5c00ff68918371243be158031e9554fa
-EBUILD sphobjinv-2.1.ebuild 1408 BLAKE2B b819c6a50a974c96db2c49807dff7c9dc3e00ef75f4a9f037b1f7b5695ca4fdf804397d42fdb5ced13b009e3c00657336504889a83772baf4b450c62c9d29875 SHA512 d5348e058f003fc4354090115b360cd9e12d31cda7e018458d4951b8207cc532bd6cb19213c7052a3fa2d1cafe28774d1e13ae68417b3780338c6ed99f9ced38
+EBUILD sphobjinv-2.1-r1.ebuild 1363 BLAKE2B 77b597267459fee07588a91f4d1bf374bedb8f21b1f4c814c2f2217739527a3293cdf63a4dde0aaa0238de9264cb15e2f4d2baa7d6136e69cda82b057fb9b0c7 SHA512 50c5c7f668c8fed92f43bdfd95ffd369252e10f73de234684a9b55238cf14c497731917f18d7d2c3d5187862244c74f53870a1969596fe7fd61f985ae300245f
+EBUILD sphobjinv-2.1.ebuild 1407 BLAKE2B 8695c5392eb2d5440024befdca08563838dedfe1aca714dfb84d276c7bc75ac4150e4d5d98774734f51ffc0790b9c35e90d21e9e81b6333e64e1d6e40dd4c91c SHA512 df353ad06369be41d9dd815ab5abb5c24daea166931a563005425f83687d724368ad4bf5f5be7b3104b0f440269038726ea696cd9d830aadc15a3df1b1e7f6a4
MISC metadata.xml 894 BLAKE2B 9e3b9ad864c23cd1cf346de1c06bf25035de4566733c1716846267aeba3aa09c025e04b15b67369e74f703e4b3205d89e35fd6614627d9f5630fd233320843eb SHA512 f5407da0c6c12279317b17d7174627d1fc3a42f249c1e63acd73c0367c526aab6b62fd358a34760c4986d3d487839905e2ddf5e40c62668933280c5278fefd9e
diff --git a/dev-python/sphobjinv/sphobjinv-2.1-r1.ebuild b/dev-python/sphobjinv/sphobjinv-2.1-r1.ebuild
new file mode 100644
index 000000000000..e5d408e9b3af
--- /dev/null
+++ b/dev-python/sphobjinv/sphobjinv-2.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx objects.inv Inspection/Manipulation Tool"
+HOMEPAGE="
+ https://github.com/bskinn/sphobjinv/
+ https://pypi.org/project/sphobjinv/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/fuzzywuzzy-0.8[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/dictdiffer[${PYTHON_USEDEP}]
+ dev-python/pytest-check[${PYTHON_USEDEP}]
+ dev-python/pytest-ordering[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/stdio-mgr-1.0.1[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx doc/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues \
+ dev-python/sphinxcontrib-programoutput
+
+python_prepare_all() {
+ # --strict option is deprecated in pytest>6
+ sed -i -e '/addopts/d' tox.ini || die
+ sed -e '/CLI_TEST_TIMEOUT/s/2/20/' -i tests/test_cli.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/sphobjinv/sphobjinv-2.1.ebuild b/dev-python/sphobjinv/sphobjinv-2.1.ebuild
index 47ea2e1ec337..fd89afa41e92 100644
--- a/dev-python/sphobjinv/sphobjinv-2.1.ebuild
+++ b/dev-python/sphobjinv/sphobjinv-2.1.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 sparc ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 sparc x86"
SLOT="0"
# This requires pytest-check, but that does not work at all, even if it