summaryrefslogtreecommitdiff
path: root/dev-python/sphinxemoji
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-06 15:58:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-06 15:58:48 +0000
commit6404f9556c73d558d61c2eed022743311eb43bb9 (patch)
treecc98afde6cd3539e2dda3dae5e467992b03d2367 /dev-python/sphinxemoji
parenta03b2fe2d845ae950995bf1c5255da420cbd92d2 (diff)
gentoo auto-resync : 06:02:2024 - 15:58:48
Diffstat (limited to 'dev-python/sphinxemoji')
-rw-r--r--dev-python/sphinxemoji/Manifest2
-rw-r--r--dev-python/sphinxemoji/sphinxemoji-0.3.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinxemoji/Manifest b/dev-python/sphinxemoji/Manifest
index 794d7e7b046e..7ed071075e1d 100644
--- a/dev-python/sphinxemoji/Manifest
+++ b/dev-python/sphinxemoji/Manifest
@@ -1,3 +1,5 @@
+DIST emojicodes-0.3.1.gh.tar.gz 47298 BLAKE2B 95dc98f737d66005e101955d9da8e4a1509fbf780316a9be8050f086c4d951144de6fa016fbf7215b48e1f4f0155c11001ccc689f4537cf93bda9d4c61d3340a SHA512 1253845bd6a9ffc53a9a649a795b29fab8980f2020e86802479f886b819e8b345f94e6c1fc5f4597c5096cd3fb8bdf31389c7ba02839d7fc145d43ce914e235e
DIST sphinxemoji-0.2.0.tar.gz 44431 BLAKE2B 18c9a7b4c97bc6081216cac98cecf41fef0bfc90122bd24f7d11d96f5db71437ee4e80675464fcaf9bc4c6e89c2511392600e043d4fb1904cfc57ce4efbed824 SHA512 974fcfad13f326265c679a3c97fd251b0348499fc9a72b65547b2548ddb2eb895a96f71d4b212f619287ac7c759df22fbb66f1a8cfa160287f8b25878c0f0515
EBUILD sphinxemoji-0.2.0.ebuild 515 BLAKE2B 4746905a06a1563497f6e4b9601e8c7747afd4fdda033aaf2362d23d767bb1f540d1b7905ecda56bbf5418d1364553524b62b70f3b22b1a1cdd2bab86b461796 SHA512 0244f4e7d0175a1e92a95b1aea4243d323ecd3214b16c34b5fe9f74ad2e8eb7942c3a10fe7849ea54880f2d011d9a0ebc1433cfa73f611e34d52a59e5a14e410
+EBUILD sphinxemoji-0.3.1.ebuild 777 BLAKE2B 0065976e88720c5d2f0dcaa1bd9a055e403b0c7b0ffb17fc34f7fb78b5d23e34fd125a1a16cff5ec35723f57487aea68294e1b4d907c37529d4bb490a74f0f17 SHA512 862725947c54095beb3f47cfae7c4b5059d47addf26ea2719ca8147f3a46419a59bd3a8e3801e742c1c879900ca453c0e75928d41c0d0fbac14d8be36be42c23
MISC metadata.xml 404 BLAKE2B 5a14c2f756212767626a1787201b21b8a89a6c555baa9b7edfd22a9b5638c0897512d736916cae9b95dacc4483465b38c601f53098425c384ad7a941816d5678 SHA512 ddc72d3a945910f3ff30172ad888305a50b42599cd92e61ec39d141bfee3135ea68fbae3855d0cbbc725f4608b99de7b8f4af354ebbb108db7940a8ec6592fd1
diff --git a/dev-python/sphinxemoji/sphinxemoji-0.3.1.ebuild b/dev-python/sphinxemoji/sphinxemoji-0.3.1.ebuild
new file mode 100644
index 000000000000..accb0a0592a8
--- /dev/null
+++ b/dev-python/sphinxemoji/sphinxemoji-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=emojicodes-${PV}
+DESCRIPTION="Extension to use emoji codes in your Sphinx documentation"
+HOMEPAGE="
+ https://pypi.org/project/sphinxemoji/
+ https://github.com/sphinx-contrib/emojicodes/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/emojicodes/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-5.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local HTML_DOCS=()
+ build_sphinx docs/source
+ rm -r docs/source/_build || die
+}