summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-websupport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
commit721254b86a09bdedd5eefd0de7899c90ea2ead1a (patch)
tree895fca7b3bd570d8df743dd518a6f36deca1a241 /dev-python/sphinxcontrib-websupport
parent618c3037024b4e5328531cdc07c6ceb7486f5329 (diff)
gentoo resync : 01.01.2018
Diffstat (limited to 'dev-python/sphinxcontrib-websupport')
-rw-r--r--dev-python/sphinxcontrib-websupport/Manifest2
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.0.1-r1.ebuild (renamed from dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.0.1.ebuild)23
2 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/sphinxcontrib-websupport/Manifest b/dev-python/sphinxcontrib-websupport/Manifest
index e2ad74948297..5c4b598d7ab0 100644
--- a/dev-python/sphinxcontrib-websupport/Manifest
+++ b/dev-python/sphinxcontrib-websupport/Manifest
@@ -1,3 +1,3 @@
DIST sphinxcontrib-websupport-1.0.1.tar.gz 590480 BLAKE2B 1be40595094233ca2ddb1a367039320fe6655b1a6bbf251d7722b60efe0d0cfbe1cdb38455f47f4fb6810500e0e4923f5a9a74df4f79d1544261c4706a59e8fb SHA512 67807b2505e063639163b020f0e62469b0c2838c303516cce9a8d90181cc7b8a10d76532adb1267556d40f95966efc20ec9f8ee1a6731056bda827a6f97f40ec
-EBUILD sphinxcontrib-websupport-1.0.1.ebuild 1055 BLAKE2B a1090cb1b847881f9aa7921e30f202ac6dd7f98be47e7ba6172510dcece12c8594f7fdcbbdef42cda96064e0c54b97e84a4f904797da7f750921e2c9887473dc SHA512 bda284d7e9773643383a99bdf5cf844f021fc4d2b15bf913107a9aa9acf713d9b15596bc83277ae1689e1fc4c8f5f22d416e7648722430ea6091c5ae949e29e0
+EBUILD sphinxcontrib-websupport-1.0.1-r1.ebuild 1138 BLAKE2B 9a14b7decbe8e5891c613b5ecb7249caf456b74a21cee81dc857b055b9aa9e71ae7ec27e3e9e59e38a8ef4bdbe41ac792d4fcbce0bd005f9e0273929a2956571 SHA512 87e2aba3e74875b80fb90cbba5a350f0f4276c680b101eb1fd761d35f12318dd88cf488bd0dedabba5fe635b96119820f4b77b8e54c24a4c15e0ffb88feb409f
MISC metadata.xml 588 BLAKE2B a7a777dd8df5b09707041ace4566bf80cee826c98aedc1e13b7dd48ddce2201aeaa79f2091ac549a66da2a04449f3ba69c243c8b1a44e0f0b661240b7dc2fbe6 SHA512 eeab14e556d91f99f5bff45a490eaecf47bcab9e295c992b817c94359fe87483947f43986bdf4633257b1ff69ffffd7b2f250e411e728f68b39a65f5b53a29bf
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.0.1.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.0.1-r1.ebuild
index 62634aaae3c8..acee6d134de7 100644
--- a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.0.1.ebuild
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,28 +15,29 @@ SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
IUSE="test"
-CDEPEND="
+RDEPEND="
>=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
>=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
>=dev-python/six-1.5[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}]
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
-"
-DEPEND="${CDEPEND}
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+# avoid circular dependency with sphinx
+PDEPEND="
+ >=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}]"
+DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
+ ${RDEPEND}
+ ${PDEPEND}
dev-python/tox[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
+ )"
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die
}
-python_test(){
- ${EPYTHON} -m pytest tests/
+python_test() {
+ "${EPYTHON}" -m pytest tests/ || die "Tests fail with ${EPYTHON}"
}