summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-websupport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-python/sphinxcontrib-websupport
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sphinxcontrib-websupport')
-rw-r--r--dev-python/sphinxcontrib-websupport/Manifest2
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-websupport/Manifest b/dev-python/sphinxcontrib-websupport/Manifest
index 5f2da71f666d..b9d4df64be31 100644
--- a/dev-python/sphinxcontrib-websupport/Manifest
+++ b/dev-python/sphinxcontrib-websupport/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-websupport-1.0.1.tar.gz 590480 BLAKE2B 1be40595094233ca2ddb1a367039320fe6655b1a6bbf251d7722b60efe0d0cfbe1cdb38455f47f4fb6810500e0e4923f5a9a74df4f79d1544261c4706a59e8fb SHA512 67807b2505e063639163b020f0e62469b0c2838c303516cce9a8d90181cc7b8a10d76532adb1267556d40f95966efc20ec9f8ee1a6731056bda827a6f97f40ec
+DIST sphinxcontrib-websupport-1.1.0.tar.gz 587947 BLAKE2B fafaa56071245c8934e27c6d2d7752745b2a8047c8a30d52e513fff7f952086a1b9082aa15e15ef232d69ef0c0d5d117f8a8c97fcdf9cd90c89d53238d7f322e SHA512 adbd7db06150a4424a881a22442c2535ed823c7adcc295ef9c3af5ae38d823349830a114e8a7af2138498d0e68b37189707c1bb5a28b45c76031bcf94210fb89
EBUILD sphinxcontrib-websupport-1.0.1-r1.ebuild 1156 BLAKE2B 00ee805df4ad56c92db8915d108723903c353ea59e5456d8dd79ee2789420cf6927c1bd5cb221b65c44e4d2a252c922ee93e8cdb464217dd24deacf444e9343a SHA512 c945062bd412b2e91df3f26cc362109c63973f8f87ba25f409896433e53b943c36e3900333fba5000299228f5eda997aab7d4139d73fa77bda098a1b48698d37
+EBUILD sphinxcontrib-websupport-1.1.0.ebuild 1118 BLAKE2B f304a77363ff04cbf2ece74b5fbc598bb39897cc50cb469428823c15557764db1ef6f7495d12a9415e8323345fd0f4fc158706b032324ad9bf23064649447a97 SHA512 ff2d6deb2785e330f3552bcbc32cb2a45115595efdbdf5ad2b801e7b959a68a21eb7882f7da3154252595895253d87c24afbee525b7cd68ab12bf446b9b25df2
MISC metadata.xml 588 BLAKE2B a7a777dd8df5b09707041ace4566bf80cee826c98aedc1e13b7dd48ddce2201aeaa79f2091ac549a66da2a04449f3ba69c243c8b1a44e0f0b661240b7dc2fbe6 SHA512 eeab14e556d91f99f5bff45a490eaecf47bcab9e295c992b817c94359fe87483947f43986bdf4633257b1ff69ffffd7b2f250e411e728f68b39a65f5b53a29bf
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild
new file mode 100644
index 000000000000..36f4308b2e8e
--- /dev/null
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx websupport extension"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
+ >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+# avoid circular dependency with sphinx
+PDEPEND="
+ >=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ ${PDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ pytest -vv tests || die "Tests fail with ${EPYTHON}"
+}