summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-websupport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-python/sphinxcontrib-websupport
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-python/sphinxcontrib-websupport')
-rw-r--r--dev-python/sphinxcontrib-websupport/Manifest2
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild9
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/sphinxcontrib-websupport/Manifest b/dev-python/sphinxcontrib-websupport/Manifest
index b9d4df64be31..04c91177b986 100644
--- a/dev-python/sphinxcontrib-websupport/Manifest
+++ b/dev-python/sphinxcontrib-websupport/Manifest
@@ -1,5 +1,5 @@
DIST sphinxcontrib-websupport-1.0.1.tar.gz 590480 BLAKE2B 1be40595094233ca2ddb1a367039320fe6655b1a6bbf251d7722b60efe0d0cfbe1cdb38455f47f4fb6810500e0e4923f5a9a74df4f79d1544261c4706a59e8fb SHA512 67807b2505e063639163b020f0e62469b0c2838c303516cce9a8d90181cc7b8a10d76532adb1267556d40f95966efc20ec9f8ee1a6731056bda827a6f97f40ec
DIST sphinxcontrib-websupport-1.1.0.tar.gz 587947 BLAKE2B fafaa56071245c8934e27c6d2d7752745b2a8047c8a30d52e513fff7f952086a1b9082aa15e15ef232d69ef0c0d5d117f8a8c97fcdf9cd90c89d53238d7f322e SHA512 adbd7db06150a4424a881a22442c2535ed823c7adcc295ef9c3af5ae38d823349830a114e8a7af2138498d0e68b37189707c1bb5a28b45c76031bcf94210fb89
EBUILD sphinxcontrib-websupport-1.0.1-r1.ebuild 1156 BLAKE2B 00ee805df4ad56c92db8915d108723903c353ea59e5456d8dd79ee2789420cf6927c1bd5cb221b65c44e4d2a252c922ee93e8cdb464217dd24deacf444e9343a SHA512 c945062bd412b2e91df3f26cc362109c63973f8f87ba25f409896433e53b943c36e3900333fba5000299228f5eda997aab7d4139d73fa77bda098a1b48698d37
-EBUILD sphinxcontrib-websupport-1.1.0.ebuild 1118 BLAKE2B f304a77363ff04cbf2ece74b5fbc598bb39897cc50cb469428823c15557764db1ef6f7495d12a9415e8323345fd0f4fc158706b032324ad9bf23064649447a97 SHA512 ff2d6deb2785e330f3552bcbc32cb2a45115595efdbdf5ad2b801e7b959a68a21eb7882f7da3154252595895253d87c24afbee525b7cd68ab12bf446b9b25df2
+EBUILD sphinxcontrib-websupport-1.1.0.ebuild 1170 BLAKE2B 79a2ae5c6a31c14a9d78edb459adbf12d5e78926eb9ee70d7f495f5ce385123a4555b57b228b11e8c070aabf536f1b7893a8e9fd3c727e54149bfc927778d0b3 SHA512 d7756f95e32588800d771a6d3bde9dc2b398f40818f01597d7a41cdaa4a4f73efaa839c4d1a9fc93f7842df29c35d27b7eeeee0b0993d65ead90ea94824fbdb6
MISC metadata.xml 588 BLAKE2B a7a777dd8df5b09707041ace4566bf80cee826c98aedc1e13b7dd48ddce2201aeaa79f2091ac549a66da2a04449f3ba69c243c8b1a44e0f0b661240b7dc2fbe6 SHA512 eeab14e556d91f99f5bff45a490eaecf47bcab9e295c992b817c94359fe87483947f43986bdf4633257b1ff69ffffd7b2f250e411e728f68b39a65f5b53a29bf
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild
index 36f4308b2e8e..ac62b3309fa2 100644
--- a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.1.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
inherit distutils-r1
@@ -37,6 +37,11 @@ python_install_all() {
find "${ED}" -name '*.pth' -delete || die
}
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}
+
python_test() {
- pytest -vv tests || die "Tests fail with ${EPYTHON}"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}