summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
commit796e724b5ace96ff70d918765662edf62f1d8c85 (patch)
treeb09742996db0de2a2414587542b1b91d4ae5c522 /dev-python/sphinxcontrib-trio
parentcd7ab3ad114e9777d85ced67abdd5b25d0bd4efe (diff)
gentoo auto-resync : 09:07:2023 - 22:25:43
Diffstat (limited to 'dev-python/sphinxcontrib-trio')
-rw-r--r--dev-python/sphinxcontrib-trio/Manifest1
-rw-r--r--dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-trio/Manifest b/dev-python/sphinxcontrib-trio/Manifest
index a1a4cd9ac635..1b9708bf3bb8 100644
--- a/dev-python/sphinxcontrib-trio/Manifest
+++ b/dev-python/sphinxcontrib-trio/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib-trio-1.1.2.tar.gz 24131 BLAKE2B 5ddaf5ed6c85905275e206fdd966745ce4dd7296595c488864df291cb7202725ccab722f306dd9d6c27d660f5cb3e43bf9ab2fe50e8aa5a7232c2615dddbdfd0 SHA512 cb90f37f463fbdd3f810eb6d76b4bdaaabe83317de0ad747fcee55980849d691e272884ecdfcbee58851cf536f268f2520caba281d7550fe3250e92c69164434
+EBUILD sphinxcontrib-trio-1.1.2-r1.ebuild 1102 BLAKE2B 0e25184655ac988fdf0f56069bb7fdc582a2004c4512b921e3f1e001510b9c35f7aacb6d7f37112089968c3a592134910a451c10bad8b005ded31ce888cbbd19 SHA512 a9c992fd784debc5ce14a96c1a2fbc8ba8fae1d7e6eac79f6b269cf77000c68a04cf8b1529660dfd49cfbbed23c2418d6a99da6ab1ea79027059304dd05e1a05
EBUILD sphinxcontrib-trio-1.1.2.ebuild 983 BLAKE2B d2be6677eecea0219121f32516c1de3579c00f76e559b094ed6ac270ada4af6d11f3ba7153a8ac7df9ced02dcf976bfe5049b7eb1df3ad8294228301a99feef1 SHA512 613e07c9f22bf65186de66d7db766e0d6d8f69809d474572a74c1da9516a86a7de609b7a305ec24c0942361d32e10564d512660798a89d1a40c8c7839cbcdc60
MISC metadata.xml 1118 BLAKE2B f86bb065d9a5073e419a2c34c88412f0340de6e444afc26ee316a05b962699dd744a790758e2409d3d0b32378d865f66d8d7e8392fdd4523b393566caf67e65a SHA512 a16c4e89c6be00a81c3278f8c8ebe6cd75d1b1cba1e8c9f9d1aa4d2bd318073687556adf91f44c1cd39c2e26a179153b1bbee501101fe26d154f1d69a1a2d376
diff --git a/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..c6ed42088b64
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Make Sphinx better at documenting Python functions and methods"
+HOMEPAGE="
+ https://github.com/python-trio/sphinxcontrib-trio
+ https://pypi.org/project/sphinxcontrib-trio/
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+)"
+
+# AttributeError: 'Sphinx' object has no attribute 'add_stylesheet'
+#distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/python-trio/sphinxcontrib-trio/issues/260
+ local -x PYTHONPATH="${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages"
+ epytest --deselect tests/test_sphinxcontrib_trio.py::test_end_to_end
+}