summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-29 15:34:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-29 15:34:19 +0000
commit67c78fc4ac5b7eada5a0196fa051b16628dac90c (patch)
treec3f41edf3185d25cbe9a93ad5ed6bb625f661e37 /dev-python/sphinxcontrib-trio
parent704343381e435b306648a2d85a77a58e34478643 (diff)
gentoo auto-resync : 29:10:2023 - 15:34:19
Diffstat (limited to 'dev-python/sphinxcontrib-trio')
-rw-r--r--dev-python/sphinxcontrib-trio/Manifest2
-rw-r--r--dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild23
2 files changed, 16 insertions, 9 deletions
diff --git a/dev-python/sphinxcontrib-trio/Manifest b/dev-python/sphinxcontrib-trio/Manifest
index 58f7c47eade6..eb2840361824 100644
--- a/dev-python/sphinxcontrib-trio/Manifest
+++ b/dev-python/sphinxcontrib-trio/Manifest
@@ -1,3 +1,3 @@
DIST sphinxcontrib-trio-1.1.2.tar.gz 24131 BLAKE2B 5ddaf5ed6c85905275e206fdd966745ce4dd7296595c488864df291cb7202725ccab722f306dd9d6c27d660f5cb3e43bf9ab2fe50e8aa5a7232c2615dddbdfd0 SHA512 cb90f37f463fbdd3f810eb6d76b4bdaaabe83317de0ad747fcee55980849d691e272884ecdfcbee58851cf536f268f2520caba281d7550fe3250e92c69164434
-EBUILD sphinxcontrib-trio-1.1.2-r1.ebuild 1094 BLAKE2B e24f420bb83ad91ef60559c959b5f73f50c6cab60216c10bd8d24fab53a632a05312a2ff850d471a85b6c3d6abf8a232d3b93ca4dfe1a0f32b0b82eb4d44409a SHA512 462961c987e3493e04d9b623ec4e4ccb05cf25af0a4b7b32de3fce09da1d393ff5df18c311d1d6a2cae0f2d370477c787d588361ef043dd4525df1857896b0cb
+EBUILD sphinxcontrib-trio-1.1.2-r1.ebuild 1063 BLAKE2B b66483f175bd61e41e442322ae233981b2875d8d4a816f7538aedd25a9571141655db266986db112dee3c482bed93e04b2f4f9712fea9c4c0d68ba2a62736390 SHA512 de526ec7485539ccbfe875a3ac0bb76720478087c0c423d0e78f068a7eafe8325c159722f5c9a2cffe216037a568f5dc641caf7768a77d75c2054937cafb3c3e
MISC metadata.xml 1118 BLAKE2B f86bb065d9a5073e419a2c34c88412f0340de6e444afc26ee316a05b962699dd744a790758e2409d3d0b32378d865f66d8d7e8392fdd4523b393566caf67e65a SHA512 a16c4e89c6be00a81c3278f8c8ebe6cd75d1b1cba1e8c9f9d1aa4d2bd318073687556adf91f44c1cd39c2e26a179153b1bbee501101fe26d154f1d69a1a2d376
diff --git a/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild
index be14180a3062..66e52305a688 100644
--- a/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild
+++ b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild
@@ -3,9 +3,10 @@
EAPI=8
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1 pypi
DESCRIPTION="Make Sphinx better at documenting Python functions and methods"
@@ -18,21 +19,27 @@ LICENSE="|| ( Apache-2.0 MIT )"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
SLOT="0"
-RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
- dev-python/async_generator[${PYTHON_USEDEP}]
dev-python/cssselect[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
-)"
+ )
+"
# AttributeError: 'Sphinx' object has no attribute 'add_stylesheet'
#distutils_enable_sphinx docs/source
distutils_enable_tests pytest
python_test() {
- # https://github.com/python-trio/sphinxcontrib-trio/issues/260
- local -x PYTHONPATH="${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages"
- epytest --deselect tests/test_sphinxcontrib_trio.py::test_end_to_end
+ local EPYTEST_DESELECT=(
+ # https://github.com/python-trio/sphinxcontrib-trio/issues/260
+ tests/test_sphinxcontrib_trio.py::test_end_to_end
+ )
+
+ local -x PYTHONPATH="${BUILD_DIR}/install$(python_get_sitedir)"
+ epytest
}