summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-python/sphinxcontrib-spelling
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest2
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index e11d421dd97c..4810da0de71f 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-spelling-7.1.0.tar.gz 49353 BLAKE2B 59e1f5e3fadeb175fb3d1b7a77acdb23e532456de053f886507c76189bf5f657a948d6288625110ccacfb5b673f23d209e6164f3535da30559f0ac4e792f34e9 SHA512 b8ae9ad79afacd362a986dc63d3be87b91d3560333bbcb026ab7d64fa8139e05e048d5e868df0fc40a159a3c44aeac01191df5ef8208bbcd7e35242f9a0b97be
+DIST sphinxcontrib-spelling-7.2.1.tar.gz 49584 BLAKE2B 7211acfe344b157c0d44f356aef4c31fabcb1b30256cec1693fa67d2652d80c8f3657441c193f82ef26e0e7acd7d141732bef0704462a292355d70a18ab3c2be SHA512 e9b9709b627545e1191d64753c97c0cf65e100d5379e7cc1da46faf9c5d5ea0eeb6c7aafe99331f9518488fb0801c245e0c1fa9853360bb6cf373515a4fed2ed
EBUILD sphinxcontrib-spelling-7.1.0.ebuild 1294 BLAKE2B 5263b8983129d0c294052eba258e2a377fb447bab21547e75480aef2e595e85366b5bad1955bfdc8705797caf7c8592cde2dc80fdfeae5e7ae793b4758aa26ad SHA512 7ba4902205d9c745dc61141cabfffbd48cadc9e18ebf92bff0461a80eaae1785d2d7c50a6edae059a88fff3dc43366dbeae1640306df74e1a19c37fa2b8ea245
+EBUILD sphinxcontrib-spelling-7.2.1.ebuild 1256 BLAKE2B 50dc85cef7ab7aac2b2988c64cb57305e9209e700c673b6738d94a7940312406e69d6d82dc4f6b92aed0dd9f25748686efd667a5a4c59a376e90607938f69770 SHA512 ce7172e0eb17a889d5b66c25dffbf7741bbb688cf1cfd48ad9160c64d7b3ee447fffc7ec9ead8e804f59520d1620255da4600981baf186661edc020ab80568cf
MISC metadata.xml 450 BLAKE2B a64fc81ee1b159f6ad2d8fe754cfbb8be207a77d128d01cb7cc0d46b6ba4deea1e49e49654a6b0759699d4dbddcede66cb38457c0b476e4120eb3bd5d34cd37b SHA512 0decb41e64275e11d327f2025732865ac4469b7dffe45386b100f6813df5554e71097bd957f57331856d64c9c8c89ad371abfbb25e0db54f3bf7efe2c85ad1ec
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
new file mode 100644
index 000000000000..28d6e037b439
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+# The doc can only be built from a git repository
+distutils_enable_tests pytest
+
+# We don't want distutils_enable_tests to add the namespace
+# package to BDEPEND under "test?". Therefore we add it to RDEPEND
+# after running distutils_enable_tests.
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local deselect=(
+ tests/test_filter.py::test_contributors
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}