summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
commit4828c25c25aacf399de429d381288982fd7e0d0e (patch)
treea265b5f79cf1b578c4e54483be1466f657f4baba /dev-python/sphinxcontrib-spelling
parentf8d671851faf1ca201cec0490ead4642c8987bae (diff)
gentoo auto-resync : 14:11:2022 - 00:49:44
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest2
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.7.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 398c78670bce..681aa57bd75d 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-spelling-7.6.2.tar.gz 57029 BLAKE2B 0e4cbdb167afbb5e2b60e8bae7e3b3ca8993e32495e5005e3889e8e34199f76deca8e1414e7a702b20a1c2600b9cc56781fa358a707eb1949e2491fe400aff70 SHA512 ab320b442727770ee86e1007bfda62799eb82e851a4dff48613be1bb597148255a0067d99ec4b6de912f1c46f466c691cab175bef98af501a166974946c1e8ae
+DIST sphinxcontrib-spelling-7.7.0.tar.gz 57444 BLAKE2B 22491369888d632cf158013cb3634e110f3c6a34c59e410a10081f5d1857b85b66f62caf8987058c133f80a8230733fc6e749404207503f0b2441a152fdd5118 SHA512 3599e2d0bcb9bf908b3e6f41184256114e4ab5378543be8bfdd4f55dca249c4feb4fbfda8db4495acfa72fd9ac6c416a0c988f5d30f530eb8deebbcee5833245
EBUILD sphinxcontrib-spelling-7.6.2.ebuild 1026 BLAKE2B 63fb36f0d5e11274574acfad2a86be588f95ee6d270fb761390ac6d676688ab9f4b6c93bfc0239d47c0e9ac14f559ad4f403907d62af71daa92927f902a4db24 SHA512 34903f8138bcd4cf5c85de0a112d4210e3a4c2cfd3bfd61a91571ced19d43997f5c17750656d6b775f6f6356e36765a09b21ad5e97b642ab1142939ea4f9e8cf
+EBUILD sphinxcontrib-spelling-7.7.0.ebuild 1033 BLAKE2B cb0f2310e25fe207a31b8889d842341efd0683a699f0a959f9f1a5962a52a6d658ffd56936951c1e540a8f0eccd6a7c3cb0e42c916303365fa26c9b32d152ec2 SHA512 140bbb72d466bd6766fd004bd537bdb18981f145e310c05b0ec318d735a4f557bf5061fab31d3ffb49031e7027f6bb4e5610a7f1bfdb6203ea9e619c15fe013d
MISC metadata.xml 451 BLAKE2B fa659ac4949e98ca8c5a11a9b72ecba8a69ca94d95f8ab5f07c0d43d9684cd1cd21dbd63f42928a9920001904a6f75aa5663a3d924b02910c78b7894f6011722 SHA512 fead100dcd4c1d85e29260a60178e1b866ceb1f944c73fffcc051e2cfb1e96cc2e61bcf94379c0dcf84bed1349abaceb86ca9a89f2b1a8ddd384c14997d1a159
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.7.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.7.0.ebuild
new file mode 100644
index 000000000000..834977197c58
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+ epytest tests
+}