summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 08:19:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 08:19:52 +0000
commit0e2545bd942206b16391a6d7a256a5ef3ef497e7 (patch)
tree150f1f075f8a1fcc79cfec68d157b7c4979ce405 /dev-python/sphinxcontrib-spelling
parent8dd17625671faf6a47abf31d4c96a1e20d764ba5 (diff)
gentoo auto-resync : 20:02:2023 - 08:19:52
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest2
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 0f92b89542b1..e700aa6099c1 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-spelling-7.7.0.tar.gz 57444 BLAKE2B 22491369888d632cf158013cb3634e110f3c6a34c59e410a10081f5d1857b85b66f62caf8987058c133f80a8230733fc6e749404207503f0b2441a152fdd5118 SHA512 3599e2d0bcb9bf908b3e6f41184256114e4ab5378543be8bfdd4f55dca249c4feb4fbfda8db4495acfa72fd9ac6c416a0c988f5d30f530eb8deebbcee5833245
+DIST sphinxcontrib-spelling-8.0.0.tar.gz 37610 BLAKE2B 8ae9fb62a5a7d35194884ce075b27b0e54f54c18d55f9573bc53ef7b2f953011655631e37ac3bb7c988df470c8cdf1cb576e4830c61fddc068e50d382d067751 SHA512 0d8c21ea660516238c43fabb505666dfee15abb39f538c40c6b61f91e20c246b16aa170cd444263507dd51913a27fc7719cddb28f30eab26825b565f70dd3ab6
EBUILD sphinxcontrib-spelling-7.7.0.ebuild 1026 BLAKE2B 77d65a0144228d7f5707506708df672a9280c38bd26c9f3f50bbcfed66721d9457a9210b4c58ad5946aaf45adf138b55b9790375e5087f4611f067ebdbc1683c SHA512 d10df449b59d0391e5681f8e69ebedf7f5b4b12616815cdc22f7a8d46c294f5ece7d7af6029b73eeb4eef766a658b5d85530bd242ead48c9770d595b4676375f
+EBUILD sphinxcontrib-spelling-8.0.0.ebuild 1022 BLAKE2B 66e08f13e20da8b89a7124b6a583ee3bee8a1f92247475fd9173c302511d0f5d51abcc71f3c60acd45d96bf6cc1af377ea3bb2d2268ff06ddf59ef649507dbcb SHA512 40bd68fbed3322b496d4034c13dc367ebf6585c84b92e7668f37577c61498d01d7750363e7c38b7ef16385701a69965e0df6c60603c281a83838dd97be3b7330
MISC metadata.xml 451 BLAKE2B fa659ac4949e98ca8c5a11a9b72ecba8a69ca94d95f8ab5f07c0d43d9684cd1cd21dbd63f42928a9920001904a6f75aa5663a3d924b02910c78b7894f6011722 SHA512 fead100dcd4c1d85e29260a60178e1b866ceb1f944c73fffcc051e2cfb1e96cc2e61bcf94379c0dcf84bed1349abaceb86ca9a89f2b1a8ddd384c14997d1a159
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.0.ebuild
new file mode 100644
index 000000000000..80a2a89145ae
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pyenchant-3.1.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+ epytest tests
+}