summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
deleted file mode 100644
index e499df72fce5..000000000000
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx spelling extension"
-HOMEPAGE="https://github.com/sphinx-contrib/spelling"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/pyenchant[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- app-dicts/myspell-en
- )
-"
-
-# The doc can only be built from a git repository
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- tests/test_filter.py::test_contributors
-)
-
-# We don't want distutils_enable_tests to add the namespace
-# package to BDEPEND under "test?". Therefore we add it to RDEPEND
-# after running distutils_enable_tests.
-RDEPEND+="
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
-"
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}