summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-serializinghtml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/sphinxcontrib-serializinghtml
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/sphinxcontrib-serializinghtml')
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/Manifest2
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-serializinghtml/Manifest b/dev-python/sphinxcontrib-serializinghtml/Manifest
index 0242a6c8ee56..7ff6402b764a 100644
--- a/dev-python/sphinxcontrib-serializinghtml/Manifest
+++ b/dev-python/sphinxcontrib-serializinghtml/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-serializinghtml-1.1.4.tar.gz 18647 BLAKE2B aa5dcbacf28a0433cbe86d9da3f6dc5859ec6148f74714654f5095ed1f21042e0d4ab1cbfb1bc816c1de40136ac51cb6f78c913cebf5465a4a11c25b22b36a14 SHA512 d132f75f1e0491167cd6d0f5b3697ac0fc1b16e63fd3dcd480b961e332b521932e405679a695522a4aeb56f57949eb9b1ed7635e9807dd059ae44a6384bdc6d0
+DIST sphinxcontrib-serializinghtml-1.1.5.tar.gz 21019 BLAKE2B e2da8b1e1300a327b8d508ce98e7c0d3eff1e0cea28cd874df4fbd9ed0bd4de6c17e107e622ec72e00bb237025ae26b2c5aaa33b2156cee2fad7c8f8d2c65ed5 SHA512 c5aabe4d29fd0455c269f8054089fdd61e1de5c35aa407740fc3baae4cfb3235d9fd5515c0489b0becd12abc8f18d0f42aa169ed315c00f30ba87e64ce851667
EBUILD sphinxcontrib-serializinghtml-1.1.4.ebuild 900 BLAKE2B 91819fd2ab09f086d43eb83e921a39feb186fe8d1b457981cccde0b20552fc4227542c767507b73e6b4241f5d53de6fb40237ba1b0a4f6e4f8f2273275dd40d5 SHA512 22a872ee63762ce8e34a3e96b9542189a927f1480b5b8914f05d7b6247fd4e17f5f67806fed9be17077c4a1ac197ca45b1be4e2721d91c72c673816ca4b62eb4
+EBUILD sphinxcontrib-serializinghtml-1.1.5.ebuild 867 BLAKE2B 967f55176b960c52f018704821a372ffbbaf7bca632717bb1c34038f2c5c2f45cd49c7b16f3f6617d41feb4a64a671afaf4d9f41d9393c0b87140e7fe098ec18 SHA512 56905b07ed3666276eee64c24aac5ee4eeb7b74f6b86b667cf8de1ad7d020e63063014779928e6dbafb3f8d209cb4b671c0465a59a99b58ddd527d500a5c1370
MISC metadata.xml 436 BLAKE2B 1ff1b18113f36620c2fbab9af2fcb1ba8e827f5a3aa3ddd0eca46d40afbef8c6835f0b0df1e49e9783974aa536d1450f5bdfe8c5e1764e17339f5ebdb8dbd74c SHA512 ce1452b75f6f585ff90a1da0b6455693b18f462ec97bb4afe1ddefa2a1a684fcf87928a35911ce0fb99f2f4f039ab580bb4f17efc375930d57d788a00084936b
diff --git a/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.ebuild b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.ebuild
new file mode 100644
index 000000000000..1ad6f58cf77c
--- /dev/null
+++ b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs outputs serialized HTML files"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-serializinghtml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}