summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-serializinghtml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-10 09:32:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-10 09:32:05 +0100
commitd087665a0d6764fc223d2f88a04db01d76af9cc0 (patch)
tree698510baa01e5c4c92f7867e40bed45acd5f4547 /dev-python/sphinxcontrib-serializinghtml
parentd8e832445899a9a8ba4d8dc6f61f5feca79a3b85 (diff)
gentoo auto-resync : 10:08:2023 - 09:32:05
Diffstat (limited to 'dev-python/sphinxcontrib-serializinghtml')
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/Manifest2
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.7.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-serializinghtml/Manifest b/dev-python/sphinxcontrib-serializinghtml/Manifest
index 7e92765b262e..c571f5474e8b 100644
--- a/dev-python/sphinxcontrib-serializinghtml/Manifest
+++ b/dev-python/sphinxcontrib-serializinghtml/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-serializinghtml-1.1.5.tar.gz 21019 BLAKE2B e2da8b1e1300a327b8d508ce98e7c0d3eff1e0cea28cd874df4fbd9ed0bd4de6c17e107e622ec72e00bb237025ae26b2c5aaa33b2156cee2fad7c8f8d2c65ed5 SHA512 c5aabe4d29fd0455c269f8054089fdd61e1de5c35aa407740fc3baae4cfb3235d9fd5515c0489b0becd12abc8f18d0f42aa169ed315c00f30ba87e64ce851667
+DIST sphinxcontrib_serializinghtml-1.1.7.tar.gz 15313 BLAKE2B 6453e5b24be17ed10ab2c9567cac273af9941f94850388b4ef61e2114e1e1f6fd5e6fd63306107c55df068d9b4f784c6c282d8f8fba7d4b772272f6c9fa39bee SHA512 a4a3ff0b7d7ef8b9eb4e179a494b58d3358cd94837db40c19350ceb1810d9917dca8a116d624d2a679399221fc4fc06ad161d6a2735525cc43bec9826e605af9
EBUILD sphinxcontrib-serializinghtml-1.1.5-r1.ebuild 974 BLAKE2B d304b55d31159f38f1c1caa555b967d8ef7778c9fe675182f75f09f363c8619dc24c96bbaa961a5a530a49dc04090fc667e5704e9ec1a42bc56c2127173edc89 SHA512 ada070219141d175781c0eb084d369f3bef924140cef412a628c254e076727c104c4625b24474df7e79ea0e088054c206e58de0218078ccc86053fbb198a7ade
+EBUILD sphinxcontrib-serializinghtml-1.1.7.ebuild 753 BLAKE2B f6a1c9c4553fa309c58d579236ea5073e3a9bb99e28d0391c81580f5263bce06909a94a2a7ff3df5e937a4eebe851f47cd00d64c7a404472f5deb176a6422cfa SHA512 305da83b6c3128d4cbe6bc41a41302e7a770d751bd94a506f9db21218c3c6195d6cf4bad2979d597b3d1687f64680c973b3cc259d50f5e3d8584ac96e952a995
MISC metadata.xml 437 BLAKE2B 6b040f2d00f91a4f275afa689de0eb172fe59e4b16685f30181901e4abc6d72bd8684e2a5503a5712a22cd2eead81d1433a504568d9d596ed109afd632b8b575 SHA512 7606411699692a843b2ac349d9c60905009c02691e94c73dd6a271ea4ad9f2c1c5c972ff54f45612977374e7e850457dbd7ed63b2fe5f16b11c7fa45999b9f63
diff --git a/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.7.ebuild b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.7.ebuild
new file mode 100644
index 000000000000..dd43a2698134
--- /dev/null
+++ b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs outputs serialized HTML files"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-serializinghtml/
+ https://pypi.org/project/sphinxcontrib-serializinghtml/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest