summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-serializinghtml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
commit7860ad41012a3808c645607818b64ad7dab025e9 (patch)
tree102565176c19f5aef57ae4f6faecd3bded6f36ee /dev-python/sphinxcontrib-serializinghtml
parentb83f9f17a27e03508085814208cd9c89a07f1f49 (diff)
gentoo auto-resync : 13:01:2024 - 13:10:51
Diffstat (limited to 'dev-python/sphinxcontrib-serializinghtml')
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/Manifest2
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.10.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-serializinghtml/Manifest b/dev-python/sphinxcontrib-serializinghtml/Manifest
index b368078f5221..dc6cf0830b58 100644
--- a/dev-python/sphinxcontrib-serializinghtml/Manifest
+++ b/dev-python/sphinxcontrib-serializinghtml/Manifest
@@ -1,3 +1,5 @@
+DIST sphinxcontrib_serializinghtml-1.1.10.tar.gz 15592 BLAKE2B 35fd8458fbd300326b576aa798f9967a8bc4fe411a4d9ff0bfcf2f16f5945f9100480be7483fdafba1b4d11723f80b209e3cfd0e0f33dead1327105a11d0496b SHA512 e104817e8145cf99b3ca6cb548a7977d7f42dd442dc54e6de787c12722ea804e4a38bfe78bdb3d8ff5f71afc14bf4fbc84b15208d0c77790d377cf9ac91e4aa8
DIST sphinxcontrib_serializinghtml-1.1.9.tar.gz 15446 BLAKE2B 53d61209a043e7481c252e0a83f7e01e71ab2e385a28d78c9672b4a0d4fae2911ab4dff47dced09442a760872a7f63e04bae5916d9d7d96ff85c57b6f732eb7c SHA512 9e14527794a71120c1db9dc534383f3e56ee18241009aab2a04133351fc4dd56ee9ba242ad64be13faf44162e90e88109eb36a5692fb343f4bb28f43cda78bba
+EBUILD sphinxcontrib-serializinghtml-1.1.10.ebuild 753 BLAKE2B 1476ce7de457111ab21737cc696809f5336b17a36f40752e7c24ccd9428fe97d35b7959db5fd887af079b5c17d3b56add209fe57cc0ccdc0e8e79b8c34dbcc13 SHA512 a85cc5cc90ac6426391f8fe9a9d6ffe378d604425cd608a8fbbf3ccff7e03b39235792c89e4a410a42d921b0d259ce0d7310aa6aabc09e115eb1abbc81b4984d
EBUILD sphinxcontrib-serializinghtml-1.1.9.ebuild 745 BLAKE2B a1b6a6a0b7e3cf00350836b28defcfe6990f2a4b93819d4c55b2789ed10f5c9888fc4bb9f9e4f77f9f050e55a016157a267c7366222c18bc3e1a6b997cb16f45 SHA512 0880e8919c993769dac91ad32f9c0eb58f50ad6de19f12ae0162678ce90ee11601d881f73b989f48708ac0c8eac000a59bd60febbe5b5f4601e3b721a81bf217
MISC metadata.xml 437 BLAKE2B 6b040f2d00f91a4f275afa689de0eb172fe59e4b16685f30181901e4abc6d72bd8684e2a5503a5712a22cd2eead81d1433a504568d9d596ed109afd632b8b575 SHA512 7606411699692a843b2ac349d9c60905009c02691e94c73dd6a271ea4ad9f2c1c5c972ff54f45612977374e7e850457dbd7ed63b2fe5f16b11c7fa45999b9f63
diff --git a/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.10.ebuild b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.10.ebuild
new file mode 100644
index 000000000000..8c7f779f557d
--- /dev/null
+++ b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs outputs serialized HTML files"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-serializinghtml/
+ https://pypi.org/project/sphinxcontrib-serializinghtml/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest