summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-qthelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 06:14:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 06:14:44 +0100
commit78f392693b4d21958c3f9e73171c7c65cb437bb5 (patch)
treee05b652b19f3d827645eb7e05e40b956c5e24839 /dev-python/sphinxcontrib-qthelp
parent06a2593561b5f8054db8d68aa94b4338d2dd2bf6 (diff)
gentoo auto-resync : 15:08:2023 - 06:14:43
Diffstat (limited to 'dev-python/sphinxcontrib-qthelp')
-rw-r--r--dev-python/sphinxcontrib-qthelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.6.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/Manifest b/dev-python/sphinxcontrib-qthelp/Manifest
index e5694f53957f..c2803f007764 100644
--- a/dev-python/sphinxcontrib-qthelp/Manifest
+++ b/dev-python/sphinxcontrib-qthelp/Manifest
@@ -1,5 +1,7 @@
DIST sphinxcontrib-qthelp-1.0.3.tar.gz 21658 BLAKE2B 7a82e8941d49836cf3e64aabe05ba65b34596f7ba0287b4dc7ed2c5940f6944d1853790d1d52637b03d934effbba8fc5094089e2924322cf1b373432c60bce6a SHA512 29f77e4b3f1a4868c2a34dbd853415e5d813f482cd23b982aeed42d53acba09b896d77ba930c34cce8af043bb7d64a19acff610430e942038d95a410b6e0b5fa
DIST sphinxcontrib_qthelp-1.0.5.tar.gz 16505 BLAKE2B fb72e9a1149a021a2ed73fb67380c7a715d687742f7713d1471c7b372848f85f1c075a4f2a16683d1e738e885d680a77b506100eb3a687e370b460c52ed82402 SHA512 b4de2913a6f4d5d29cc69bd4e43f40761fcc9cf0c68a4f0102fe1750e319c9ed9d28962f6eabb4812c01f092428dcd5831c14f01350bf3de7b532f6ebed7a326
+DIST sphinxcontrib_qthelp-1.0.6.tar.gz 16555 BLAKE2B 7fabbd35f5ccf5895f16fd17e335268445e32ee0cb8c596c68e537169d4ad0aa3dc102ee2474c136c62676cff6ab639288c5fff4892d78a257a85a7ab963fe9d SHA512 783cd757bf262ce63f54019a5ccf1d7e6fb59e8fde07e7cfa0610bf0cd49e6e51cada9c35bf11cc5ff351904da6a69569be1d4db58d450a96375aee7bf1f34ff
EBUILD sphinxcontrib-qthelp-1.0.3-r2.ebuild 1186 BLAKE2B e0b9c0906b007e6f2a7b99d3c193d5df8a24bebf058c299431cbde0a35fc956b7157f35b5696135f0b539014c8e376a745040ba6b07a8d6575df10fcad2848be SHA512 b3451baa09869e9717f72fa4fa8fd72f2eba9c069ae5d10aa6ef7559d28f8bd3a864d3c837ab1f70d141522282e8b6fdc49ab2b5344ac611b16d900303fed399
EBUILD sphinxcontrib-qthelp-1.0.5.ebuild 722 BLAKE2B 030ce0415dd7037ddb69e797e34acbc4c7ff00f4bc37f30e03ed02bd8d13e21978824c822fbcb51e7ab09f124ee1cfb065f1fd30833c868760801dae97f71491 SHA512 b5b02ade6a5dc77b4a17ea8e3ccd0501c7fa649dddb6e59518eaf6f2ba4d855249bdfa9458dd90c1d125e622af03a86f715d3c6e73a5a29ac0ddec1b6382b464
+EBUILD sphinxcontrib-qthelp-1.0.6.ebuild 722 BLAKE2B 030ce0415dd7037ddb69e797e34acbc4c7ff00f4bc37f30e03ed02bd8d13e21978824c822fbcb51e7ab09f124ee1cfb065f1fd30833c868760801dae97f71491 SHA512 b5b02ade6a5dc77b4a17ea8e3ccd0501c7fa649dddb6e59518eaf6f2ba4d855249bdfa9458dd90c1d125e622af03a86f715d3c6e73a5a29ac0ddec1b6382b464
MISC metadata.xml 419 BLAKE2B 5a559b50428f6425568dfbae01bce3ada0905cbea24542e75122f1f3fce9e04cec6861f4d662515c7efa8c15a5b2347a83af5a2ea38326c069f9253436e7199e SHA512 559911ed37cd63368b2783fd6d65aa9b5fecc7b58422978f9d86b32eb8f50275f6b52a910ea4c73ef2ef3d081373862eff8a8e0e4098bd83c6b1cf4f06cd1af0
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.6.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.6.ebuild
new file mode 100644
index 000000000000..cc2082f368ba
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-qthelp/
+ https://pypi.org/project/sphinxcontrib-qthelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest